Flash Player blocked by Chrome



  • As of very recently, probably less than a week, I am unable to get http://www.msnbc.com/now to stream. I have gone to the URL window and set Flash to "ALLOW", but it doesn't fix the problem. I have verified that Adobe is, in fact, still installed, version 27.

    I don't know what else to try. I am experiencing the same trouble with both Vivaldi versions, 1.13 & 1.14 snapshot. (64 bit)

    Any ideas? Am I missing something obvious?

    Windows 10 Professional.

    0_1512012272223_69f1a6cb-d5a2-4bf9-90f1-d88a3d6c83fc-image.png


  • Moderator

    @daltondr Did you use the "site settings" link at the bottom of the security icon dropdown?



  • @ayespy I have Flash set to "Allow". HBOGO also stopped working, but resetting to "Allow" solved the issue for that site. I don't know why it isn't working for MSNBC. The news is pretty depressing lately anyway, so maybe I should let is stay broken.

    Oh, and I've tried with all extensions disabled, too, but site is still blocked.

    Edit: Just realized I added the screenshot to the wrong site. Replaced screenshot with correct site: MSNBC

    0_1512061821075_d727e942-8977-49bd-a987-3c4c423f590f-image.png

    0_1512064997920_0cbc5aa0-2664-4953-adfd-877e326fc6dd-image.png



  • @ayespy Any recommendations on where I can get some help on this? I thought Vivaldi forum would be the best place.



  • what do you have in vivaldi://settings/webpages/plugins/ ?
    I can't play those videos because I'm not logged in, I see a lock with "please sign in" on them



  • @ian-coog Thanks for the reply.
    Yeah, to stream MSNBC LIVE, you have to log in through your service provider, if you have one. I do, and I'm logged in. I guess that makes it difficult for people to troubleshoot.

    I checked the settings, and it was set to "Detect and Allow Important Flash Content Only". I set it to "Always Allow Flash", but that didn't help. Still getting blocked by Chrome.

    0_1512588835405_4de60a51-120c-4ac3-87d7-cbff32ce96ee-image.png

    I just discovered that there is so problem playing shows that aren't LIVE, so it seems that only the LIVE stream is not working. I don't know what the difference would be, but there's that. CNNgo LIVE streaming isn't working either due to Flash, even though I have that site also set to "ALLOW".



  • @daltondr Unfortunately, that setting has been "broken" by a chromium update.
    See if this article helps https://help.vivaldi.com/article/enabling-flash/



  • It's about time these sites surrender and stop using flash altogether, it's more and more blocked by chrome for a reason, and I bet these "issues" are effectively intentional. In 2020 Adobe will stop updating it.



  • @tbgbe @iAN-CooG So, I guess that means I have to wait until either the news sites or Chromium fixes it. That's nice.

    Thanks for the responses.



  • Set the Flash plug-in back to "Detect and Allow Important Flash Content Only".

    Goto chrome://settings/content/flash and clear the allow list.

    Add an exception for http://* and another for https://*.

    If that doesn't work, also goto chrome://site-engagement, set the site's base to 100, press enter and close all tabs for the site. (If the site isn't in there, keep reloading the site page till it shows up.)

    If none of that works, then you're out of luck.



  • When I first clicked on the link I got the notice saying I needed to install Flash. So I clicked on the globe in the address bar to display the site info and switched Flash to Allow, then reloaded. Now it says I need to sign in, I try that but run into an error on my ISP's login page. Hence no idea if it would actually work - but I'm not getting the Flash error at any rate.

    http://get.adobe.com/flashplayer/about/ shows me a "puzzle piece" icon which I can right-click on and select Enable Flash, then confirm in a pop-up at the top of the page. After that (without reloading) it properly identifies my version of Flash, and if I do reload I get to see that Flash banner above that for a few seconds. So Flash does work in whichever snapshot version I currently have.



  • @sgunhouse
    Well, it looks like I'm out of luck. I tried adding the two exceptions, but still no dice. I tried changing the base to 100 a few days ago as someone in the Adobe forum also suggested. It didn't work, either. I tried again just now, and still no luck.

    Oh well, it's not the first time Google broke something I was using, and it probably won't be the last.

    I'm having the same issues with Opera, so it's pretty clearly a chromium and/or Flash problem.

    I took another screen capture, but for some reason it isn't letting me attach any more of those. Now, I get an error message saying, "Something went wrong while parsing server response"

    Thanks for the help.



  • @sgunhouse
    Mine hangs on the blue media window with the message, "Google Chrome has blocked your Adobe Flash Player plugin.
    Run the plugin from your address bar to watch this video"
    , after the "verifying" screen, which is after I successfully login to my tv provider. Changing Flash settings in "site settings" has no effect.

    This is the exact behavior I get with Opera, now, too... so it seems like a chromium or Flash issue, with chromium being the more likely culprit, from what I've read.



  • @daltondr said in Flash Player blocked by Chrome:

    "Google Chrome has blocked your Adobe Flash Player plugin.
    Run the plugin from your address bar to watch this video"

    That's one thing that Chrome does that Opera (and I guess Vivaldi) doesn't. If you have a domain in the Flash exception list and it only covers some of the Flash objects on a page, Chrome will put the "plug-ins blocked" notification in the right end of the address field. You can then click it to "run all plug-ins this time" or choose "manage" to add to / edit the exception list (to add the remaining exceptions for the other objects). This notification won't go away unless the exceptions you have allow all the Flash objects on the page to load.

    An example of this is having only http://get.adobe.com:80 in the exception list instead of adobe.com for the http://get.adobe.com/flashplayer/about/ page.. The latter will get rid of the plug-ins blocked part in the address field.

    Opera doesn't seem to have that part in the UI. It has an allow / block toolbar like Chrome's pop-up dialog, but it doesn't have the other part.

    That "other part" though is basically telling you that your exceptions list isn't allowing all the Flash objects to load. For Vivaldi and that site, the page's JS is letting you know the same thing I think.

    Of course, that doesn't explain why https://* and http://* isn't enough to do the trick though. Maybe you have to add data:* and about:* and blob:* and site.com for example *also*.



  • @burnout426 said in Flash Player blocked by Chrome:

    Maybe you have to add data:* and about:* and blob:*

    Hmm, guess those aren't allowed.



  • One case I've been trying to get working in Opera and Vivaldi is:

    https://www.internetpolyglot.com/matching_game

    Click the play button below the words. Then, click the speaker button next to a word to play its pronunciation.

    I can get it to work in Chrome if I add https://* and http://* as exceptions, AND click the "plugins blocked" notification in the address field and choose "run all plug-ins this time". After doing that (each time after the page loads), clicking the speaker button next to a word actually plays.

    Figuring out how to make the speaker buttons work with *just* the exceptions in Chrome (as in, getting rid of the "plugins blocked" part) might help figure out some workarounds for Opera and Vivaldi for Flash in general.

    Edit: Adding just com as the only thing in the exception list gets rid of the "plugins blocked" part. But, the audio still won't play.



  • This post is deleted!


  • This post is deleted!


  • [modedit] "sidebar settings extension" and most other Opera Addons do not work on Vivaldi.
    Removed previous postings.
    Please, if there is need how to port a Opera extension to Vivaldi you should post at https://forum.vivaldi.net/category/43/customizations-extensions



  • @gwen-dragon apologies. will do so.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.