Backspace Bug



  • I just read a post here that suggested that the backspace bug has been resolved. I am running v1.0.118.19 x64 on W8.1 and when typing a forum post at another site a few moments ago, Vivaldi does still go back a page, rather that perform the backspace function. Perhaps we need a different hotkey combo tor the forward and backward functionality? <ctrl><f>and <ctrl>anyone?</ctrl></f></ctrl>



  • @K{3f3LmL:

    I just read a post here that suggested that the backspace bug has been resolved.

    I am running v1.0.118.19 x64 on W8.1 and when typing a forum post at another site a few moments ago, Vivaldi does still go back a page, rather that perform the backspace function.

    Perhaps we need a different hotkey combo tor the forward and backward functionality? <ctrl><f>and <ctrl>anyone?</ctrl></f></ctrl>

    **
    You're two versions behind the current snapshot. Go the the Vivaldi Team Blog and download the latest, and then see how it's behaving.**



  • This bug is present in the latest Vivaldi snapshot (1.0.124.2 on Windows 10) and is also present in the TechPreview version of Vivaldi on Win 7 when using vBulletin editor, version 4.2.2. Bug doesn't trigger on IP.Board forum's editor.

    Inputting numbers in vBulletin, or using key '-' on the top row and numeric '+' and '-', also triggers different keyboard shortcuts when editing in WYSIWYG mode.



  • @E.T.:

    This bug is present in the latest Vivaldi snapshot (1.0.124.2 on Windows 10) and is also present in the TechPreview version of Vivaldi on Win 7 when using vBulletin editor, version 4.2.2. Bug doesn't trigger on IP.Board forum's editor.

    Inputting numbers in vBulletin, or using key '-' on the top row and numeric '+' and '-', also triggers different keyboard shortcuts when editing in WYSIWYG mode.

    I assume you mean 1.0.129.2, I'm also getting the issue with this release on Windows 8.1 Pro. I'm sure it's been marked as being fixed a few times now but it's still there as it makes the browser unusable which is frustrating as I've been hoping to move to Vivaldi from the proper version of Opera which is getting less compatible by the day.

    Strangely the error is only happening for me when I quote a post in a vbulletin forum, when I do that all the shortcuts are activated so backspace goes back a page, number keys change tab etc. while if I type in a new reply box without a quote it works fine. It's the same with Xenforo forums, works fine with straight replies but doesn't work when you quote a post as all the shortcut keys are activated.

    John



  • @JohnMcL7:

    @E.T.:

    This bug is present in the latest Vivaldi snapshot (1.0.124.2 on Windows 10) and is also present in the TechPreview version of Vivaldi on Win 7 when using vBulletin editor, version 4.2.2. Bug doesn't trigger on IP.Board forum's editor.

    Inputting numbers in vBulletin, or using key '-' on the top row and numeric '+' and '-', also triggers different keyboard shortcuts when editing in WYSIWYG mode.

    I assume you mean 1.0.129.2, I'm also getting the issue with this release on Windows 8.1 Pro. I'm sure it's been marked as being fixed a few times now but it's still there as it makes the browser unusable which is frustrating as I've been hoping to move to Vivaldi from the proper version of Opera which is getting less compatible by the day.

    Strangely the error is only happening for me when I quote a post in a vbulletin forum, when I do that all the shortcuts are activated so backspace goes back a page, number keys change tab etc. while if I type in a new reply box without a quote it works fine. It's the same with Xenforo forums, works fine with straight replies but doesn't work when you quote a post as all the shortcut keys are activated.

    John

    Well, 1.0.124.2, was the latest at the moment of posting. :P



  • spatial navigation interferes in the navigation using touchpad, I think spatial nav should be setteable from menu options to disable it using touchpad.
    I can not select 2 words in a text using vivaldi because the 2° word is not selected because Shift+rigth arrow key starts spatial nav insted continuing selection.



  • I don't know it for sure, but it seems that the "backspace-bug" belongs to chromium. Otherwise you could activate/deactivate the shortcut in the settings - the Vivaldi-Team won't implement things like that without the option to deactivate it.
    I tried some extensions from the Chrome-store (BackStop, Goodbye Backspace!), but they don't work…
    There are other keys with shortcuts you don't need: the + and - which are NOT on the NUM-Pad - why do we need 4 keys (NUM +/- and other +/-) to zoom on pages?
    Please, please Vivaldi deactivate those "features" - they where a big point for me to switch to vivaldi. And now they're driving me crazy on this nice browser too :(

    Edit: Just perceived the newest shnapshot - those keys seems to be deactivated now :) Great!



  • @Johnny-Walker:

    I don't know it for sure, but it seems that the "backspace-bug" belongs to chromium. Otherwise you could activate/deactivate the shortcut in the settings - the Vivaldi-Team won't implement things like that without the option to deactivate it.
    I tried some extensions from the Chrome-store (BackStop, Goodbye Backspace!), but they don't work…
    There are other keys with shortcuts you don't need: the + and - which are NOT on the NUM-Pad - why do we need 4 keys (NUM +/- and other +/-) to zoom on pages?
    Please, please Vivaldi deactivate those "features" - they where a big point for me to switch to vivaldi. And now they're driving me crazy on this nice browser too :(

    Edit: Just perceived the newest shnapshot - those keys seems to be deactivated now :) Great!

    The thing is that Chromium Opera doesn't have that bug. And it's still present in 1.0.129.2 (64-bit).
    Has anybody tested the 32-bit version?



  • @E.T.:

    @Johnny-Walker:

    I don't know it for sure, but it seems that the "backspace-bug" belongs to chromium. Otherwise you could activate/deactivate the shortcut in the settings - the Vivaldi-Team won't implement things like that without the option to deactivate it.
    I tried some extensions from the Chrome-store (BackStop, Goodbye Backspace!), but they don't work…
    There are other keys with shortcuts you don't need: the + and - which are NOT on the NUM-Pad - why do we need 4 keys (NUM +/- and other +/-) to zoom on pages?
    Please, please Vivaldi deactivate those "features" - they where a big point for me to switch to vivaldi. And now they're driving me crazy on this nice browser too :(

    Edit: Just perceived the newest shnapshot - those keys seems to be deactivated now :) Great!

    The thing is that Chromium Opera doesn't have that bug. And it's still present in 1.0.129.2 (64-bit).
    Has anybody tested the 32-bit version?

    I've just tested 1.0.151.7 and it seems to be partially fixed, backspace no longer goes back a page in a text field but most of the other shortcuts are still incorrectly triggering such as pressing the number keys, dash key etc



  • @E.T.:

    The thing is that Chromium Opera doesn't have that bug. And it's still present in 1.0.129.2 (64-bit).
    Has anybody tested the 32-bit version?

    I confirm the bug is mostly fixed, but the 1/2/3…. keys are still acting wrongly on some input fields, like the quick-reply ones on some forums.

    Instead on proper reply windows everything seems working properly



  • It isn't fixed by any means – and it drives me nuts!
    Can we get this fixed anytime soon? If this isn't possible, i'm sadly have to end using Vivaldi, which would be quite sad, since i love it!

    Smartcom



  • Hi Smartcom, don´t have problems for a long time with backspace, I am on Snapshot 1.3.519.23.
    What do you use?

    Cheers, mib



  • Necroing this because it's the top result when doing a web search for this issue meaning it's become a valuable resource for those suffering the same problem.
    I still have this bug on 1.10.867.42 (Stable channel) (32-bit). Specifically I just noticed this occurring when typing a text message at hangouts.google.com. It does not happen everywhere since I observed backspace behaving properly while typing this post.

    Furthermore, why backspace in the first place? Alt+left and right has been a perfectly acceptable means of back/forward for as long as I can remember.

    Edit: For the benefit of those who search for this in the future you can remove backspace as a keybind in Vivaldi's settings as I've done. I wanted to bring it up anyway since the bug is clearly still occurring.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.