Flash autoplay dificulty



  • Since updating to the last stable version 1.13.1008.32 the flash player no longer starts automatically. The option for Flash Plugin under Plugins in settings is set to Always Allow Flash, and I have even tried changing the Default to No user gesture is required under the Autoplay policy at vivaldi://flags

    In Firefox and Opera there is an option to always remember the setting, and there is no problem in IE or SRWare Iron.

    Has autoplay been permanently disabled in the latest version of Viv or am I overlooking something simple?

    Any help or explanation would be appreciated.



  • I fear is a change in recent chromiums. So best way for a working flash is:

    • keeping ppapi flash updated (sometimes it fails to fetch updates)
    • use "always allow flash" in vivaldi settings.
    • always enable flash for this site from urlbar. (as ask could prevent flash loading)

    Then it should work as expected.
    I'm not sure changing autoplay policy is a good idea. It could mess with vivaldi. So try to leave in its default state.



  • Thank you. I had totally forgotten about accessing setting via the urlbar. However, still cannot establish autoplay.

    Even went to "https://get.adobe.com/flashplayer/otherversions/" to ensure pappi was downloaded and installed rather than "https://get.adobe.com/flashplayer/"

    Tried Content settings - Control what information websites can use and what content they can show you

    but there are only two possible settings, "Ask first (recommended)" or "Block sites from running Flash"

    As a result the "Always Allow Flash" under plugins will not remain checked and moves to either "Detect and Allow Important Flash Content Only" or "Never Allow Flash"

    Have a feeling its still something simple being overlooked since I do not see others users posting difficulty.



  • @desertoutlaw Can you share an url ? So I try if flash is working.
    It's strange. Here on 1.13 stable I see in site settings allow/ask/deny.
    Try also to revert any change made in chrome://flags (maybe some of them is locking the player).
    Worth also check here chrome://settings/content/flash and remove any site listed in blocked/allowed (mine has been always empty).
    Do you use extensions? Which ones? Try to disable them or run site in incognito to see if something is locking the player.



  • I've had this problem myself. I've done most of what was suggested with no change. I'll try some more to see if it helps.



  • Thanks again.

    I removed the changes made at chrome://flags

    At chrome://settings/content/flash there are only two settings available, "Ask first (recommended)" or "Block sites from running Flash"

    Under Webpages-Plugins, "Always Allow Flash" continues to revert to "Detect and Allow Important Flash Content Only"

    The flashplayer works, it just has to be manually started each time. This issue did not occur until I upgraded to the lasted Vivaldi version which is odd since I have never had any problems with a stable version.

    A page where I have been embedding a flash player for years is http://fubar.com/desertoutlaw

    Going to try changing the single player to a multi-player to learn if it will start automatically



  • Using a multi-player instead of a single player still requires manual starting so I'm stumped for a while. Going to walk away for a bit and return later with a clear head.



  • I have also tried everything here with no change. I may try reinstalling next.

    This seems very similar to the problem that got me off of Chrome and into Vivaldi in the first place, as far as I can remember.



  • What is somewhat funny is a lot of people do not want players to start automatically and the chrome store use to have a plug-in that would halt automatic playing but the developer removed it and is no longer supporting it.



  • It's chr62+ behaviour, they are changing this to prevent autoplay abuse (not your case).
    So, I guess that player will autoplay if people change the policy or browser settings (most users won't do this) or if you can set player as mute on start - which is probably the best choice (even if it is a compromise).
    You could add a title on player to advise chromium users to unmute player to hear tracks.
    I have manual flash activation and also after allowing the site, it still need another activation (click to play) as the "video" stream contain audio.



  • Reinstalling has not helped either. I may have to go full slash and burn on this. Start from scratch.



  • @stickmansmith I just read yesterday that reinstalling is not recommended due to the way Vivaldi does their updates; Not like Adobe or a few other products where uninstalling of a previous version may be necessary.

    Regardless, Hadden89 suggested that autoplay was changed to prevent abuse which is understandable. But I'm not done yet. About ready to go where I should not go and look at the code for a possible hack. Something I have not done for years! LOL!



  • @stickmansmith In all of this thread I don't see anyone trying to use the Vivaldi setting via the site icon in the URL field.

    i.e.
    Load tab with the site you want to activate Flash for.
    Click on the icon in the address field (just before the address; may be a lock or favicon)
    Set Option for Flash to Always allow.

    Or are you saying this doesn't work for you?



  • @tbgbe

    Well, that does work, and I have images instead of a blank space, but now there is a 'click to play' screen over every image.

    I have had the same problem in Opera and Chrome and there is no way to stop that since the latest updates to those browsers. Is there a way to remove that in Vivaldi?



  • it works, but it's a workaround, Vivaldi's Flash settings are nor working in 1.13: am I wrong?



  • @talgarik said in Flash autoplay dificulty:

    it's a workaround

    Yep, it is. And you are not wrong - there have been a few posts about it, since it started in the snapshots.



  • @tbgbe That was Hadden89's suggestion but it did not work :(



  • @efte You are correct, the player will appear but you have to manually start it. I'm trying to learn a way to enable autoplay like in the previous version.



  • @desertoutlaw Hmmm, not sure what is happening here - but your page
    http://fubar.com/desertoutlaw
    is the only one I have come across that displays the "Press to play box".

    If you try https://helpx.adobe.com/uk/flash-player.html
    Using the "site settings" and reloading, the option "5. Verify whether Flash Player is installed" does autoplay.



  • @tbgbe Yes, I am saying that did not work for me. I set it to allow and it did not change the behavior at all.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.