How to disable alt menu?


  • Moderator

    @kayovas It is a complete solution for me.

    I still don't see what the problem is. Left Shift+Alt does not open the menu.

    Only Left Alt then Release opens the menu. If one could disable Alt to open menus, then one would introduce a new problem — how to use the menus with the keyboard.


  • Vivaldi Translator

    @pesala said in How to disable alt menu?:

    Left Shift+Alt does not open the menu.

    Left Shift + Alt does not open the menu, no. But pressing Alt while Left Shift is held down does. So if you press and release Left Shift + Alt quickly it is possible to accidentally release Alt before Left shift, thus causing Alt to trigger access to the menu.

    However, this is consistent with the Windows standard (e.g. IE, Explorer, Office, etc. all function like this) and thus not a bug.

    @kayovas Does the menu open if you press down Shift and Alt, and then make sure to release Shift before you release Alt?



  • @komposten said in [How to disable alt menu?]

    @kayovas Does the menu open if you press down Shift and Alt, and then make sure to release Shift before you release Alt?

    @Komposten, maybe, but I don't care. This approach is like Steve Jobs' "You don't hold it right". I have to be careful if I press the buttons in right way instead to do my work...

    As I sad before, Vivaldi is the only browser with this problem. The "bug" has been reported long time ago, there are many complaints about it and... nothing.

    I wish to make Vivaldi my main browser, but it's not possible. Maybe the core quantity of Vivaldi users don't use second layout... I don't know.

    P.S. I bet that there are a lot more users that use 2 layouts/languages than users that use ALT to open the menu...
    P.S.2 AND that ALT-problem repels more people than ALT shortcut attracts.


  • Vivaldi Translator

    @kayovas
    You may not care, but the developers do. This is called "debugging", a process that is required to fix an issue -- you cannot fix a fault if you don't know what the fault is. Basically, the reason I asked that question is because releasing Alt before Shift opens should open the menu in every program on Windows. It is the standard (not a good one, I agree with your "You don't hold it right" parallell, but the standard nonetheless).

    I'm trying to figure out the exact situation that causes the Alt menu to open for you when you press Shift + Alt:

    1. If you release Alt before Shift then the menu should open, and in that case the question become "why doesn't it happen in other browsers, as it should?"
    2. If you release Shift before Alt, it is a bug in Vivaldi (possibly rare bug, since not everyone can reproduce it).


  • @komposten said in How to disable alt menu?:

    If you release Alt before Shift then the menu should open, and in that case the question become "why doesn't it happen in other browsers, as it should?"

    My guess: because others have complained about it and the coders of other browser added a better keyboard detection routine to avoid showing the menu if other shift keys are pressed, simple as that. It "just" requires actually coding it. Probably seen as a minor issue and with less priority by devs.



  • @komposten said in How to disable alt menu?:

    @kayovas
    You may not care, but the developers do. This is called "debugging", a process that is required to fix an issue -- you cannot fix a fault if you don't know what the fault is. Basically, the reason I asked that question is because releasing Alt before Shift opens should open the menu in every program on Windows. It is the standard (not a good one, I agree with your "You don't hold it right" parallell, but the standard nonetheless).

    I'm trying to figure out the exact situation that causes the Alt menu to open for you when you press Shift + Alt:

    1. If you release Alt before Shift then the menu should open, and in that case the question become "why doesn't it happen in other browsers, as it should?"
    2. If you release Shift before Alt, it is a bug in Vivaldi (possibly rare bug, since not everyone can reproduce it).

    Scenario for the reproduction of the "bug". Windows 10 64 bit, latest Vivaldi Stable build:

    1. Press Shift+Alt
    2. Release Alt first.

    because releasing Alt before Shift opens should open the menu in every program on Windows.

    I've just tried with: Edge, Firefox, Chrome, MS office 2007 - no problem. I've changed the keyboard layout without the appearing of any menu... I use this software every day.

    Video: https://youtu.be/Xq8mDh2v4Is

    If I could help with anything, just tell me. I'll be happy to use Vivaldi, because I like it a lot.


  • Vivaldi Translator

    @kayovas said in How to disable alt menu?:

    I've just tried with: Edge, Firefox, Chrome, MS office 2007 - no problem. I've changed the keyboard layout without the appearing of any menu... I use this software every day.

    In Edge nothing happens even if I only press Alt.
    Don't have Firefox or Chrome installed so can't test those.
    In Office 365 (Word, Excel, etc.) pressing Shift + Alt and then releasing Alt triggers the Alt action.
    In Windows Explorer (and Internet Explorer) it also triggers the Alt effect.

    So, I guess it's kinda random between programs (and versions of programs), then.



  • @komposten Just installed Vivaldi again (I left the boat when it stopped supporting XP) and stumbled on this bug.

    The reason it resembles a bug, I think, is because I have configured an extension to activate with "Alt+W" (an option that Vivaldi provides) and instead it opens the "Window" sub-menu of the Vivaldi menu.

    This is an unexpected result.
    Remember, there is no menu visible!

    I use the same shortcut to activate the same plugin in the Opera 12 and Firefox and they work as expected.

    Even if it is a feature, can we please turn it off?


  • Moderator

    @embryo The bug has been reported.

    I assigned Alt+W to open the WordWeb extension. It works fine, without opening the menu. This is true whether the page has focus, or a text edit box like this one.

    Alt, W — as expected — opens the menu.

    The advice from Microsoft is not to assign Alt shortcuts to any commands as Alt+Letter is used by menus and access keys.



  • @pesala Thank you for the report...
    If Alt+[letter] can't be used, why it exists as an option?
    The Ctrl+Alt+[letter] combo is already disabled (why is that anyway?) and I haven't found yet a shortcut to enable/disable an extension.
    I get no warning if a shortcut is already in use by something else, and my selection does not take priority over the older one.
    So, I have to select a shortcut, close the window to apply it, go to an open tab to test it, just to find that something totally different happened when I pressed the keys.
    Perhaps something dangerous too?
    The shortcut implementation is really confusing.


  • Moderator

    @embryo said

    If Alt+[letter] can't be used, why it exists as an option?

    It can be used, but Microsoft don't recommend using it for the reasons stated. It's likely to conflict with menu shortcuts.

    The Ctrl+Alt+[letter] combo is already disabled (why is that anyway?) and I haven't found yet a shortcut to enable/disable an extension.

    The Ctrl+Alt combinations are apparently not available to assign to extensions. Ctrl+Shift combinations are available if the Ctrl+Key combination is already in use.

    I get no warning if a shortcut is already in use by something else, and my selection does not take priority over the older one.

    The latest final and snapshot versions show you what the shortcut is assigned to in the Settings Dialogue.

    0_1527659458601_Already Assinged.png

    The shortcut implementation is really confusing.

    There are a lot of possible permutations, so one has to select shortcuts carefully. Unfortunately, shortcuts for extensions and those for Vivaldi commands are not linked.



  • @pesala said in How to disable alt menu?:

    It can be used, but Microsoft don't recommend using it for the reasons stated. It's likely to conflict with menu shortcuts.

    You mean "It can be selected", because, in reality it can't be used. I tried...

    The Ctrl+Alt combinations are apparently not available to assign to extensions. Ctrl+Shift combinations are available if the Ctrl+Key combination is already in use.

    Still no reason why is that...

    The latest final and snapshot versions show you what the shortcut is assigned to in the Settings Dialogue.

    Yes, but not for the extensions, which beats the purpose I suppose..

    There are a lot of possible permutations, so one has to select shortcuts carefully. Unfortunately, shortcuts for extensions and those for Vivaldi commands are not linked.

    Thats not a very thoughtful approach now, is it?
    How can I "select shortcuts carefully" if I don't know what shortcuts are already taken?
    Really, really confusing...


  • Moderator

    @embryo How can you ever resolve your problems when you are so negative?

    Alt shortcuts can be assigned. I already tried. You have to press Alt + W at the same time, not Alt then W, which will bring up the menu. Awkward, but that's what you get if you use Menu shortcuts for other commands.

    I also explained to you how to check if a shortcut is already assigned to something else. If you want to use it for an extension you can unassign it from it's Vivaldi command, then it can be assigned to the extension.

    Sorry that you're really, really confused ... but that is something that you need to fix for yourself by reading and experimentation.

    I don't know the internal workings, but I assume it would be hard to combine the shortcuts for a known and fixed list of commands with an unknown and unlimited list of extensions.

    You will be glad to here that in the latest Snapshot:

    • Allow disabling or reassiging the keyboard shortcut (Alt) that opens the Vivaldi menu

    Specs: AMD A10-6800K, 8 Gb on Win 10 64-bit •Snapshot 1.16.1183.3 (64-bit)



  • @pesala said in How to disable alt menu?:

    @embryo How can you ever resolve your problems when you are so negative?

    OK. So you think that I can resolve it be saying that it DOES work. Interesting approach ;o)

    Alt shortcuts can be assigned. I already tried. You have to press Alt + W at the same time, not Alt then W, which will bring up the menu. Awkward, but that's what you get if you use Menu shortcuts for other commands.

    Yes, you're right. "Menu shortcuts" for a menu that I do not see. Understandable.
    And i suppose that its easy to press these keys EXACTLY at the same time (all of the time)

    I also explained to you how to check if a shortcut is already assigned to something else. If you want to use it for an extension you can unassign it from it's Vivaldi command, then it can be assigned to the extension.

    Of course you did. By opening and closing two different windows for every combination I checked. It is super easy and time efficient. I wonder why am I complaining... ;o)

    Sorry that you're really, really confused ... but that is something that you need to fix for yourself by reading and experimentation.

    Agreed. The confusion is always the user's problem. If you trying to use an interface that it behaves differently than the one you already using, is your problem, not a developer's oversight.

    I don't know the internal workings, but I assume it would be hard to combine the shortcuts for a known and fixed list of commands with an unknown and unlimited list of extensions.

    The "unknown" and "unlimited" list of shortcuts is the one that Vivaldi SAVES and remembers between sessions (a known and limited one).
    Its really difficult to check in there. I can see that now. Its, really, REALLY hard. ;o)

    You will be glad to here that in the latest Snapshot:

    • Allow disabling or reassiging the keyboard shortcut (Alt) that opens the Vivaldi menu

    That would be nice. Thank you.
    I'll check it out...



  • Confirmed working in 1.16.1195.3, now who use alt-shift as language/keyboard switch shouldn't complain anymore. Menus still can be activated with Alt-letters. All good.


  • Vivaldi Translator

    @igorgl If I press Alt down before Shift, I simply cannot get the menu to open regardless of which key I release first.

    If I press Shift before Alt, the menu opens if I release Alt before Shift. The latter happens also in some other software I'm using, including Windows' Explorer, so that seems to be a standard behaviour.

    (Note: I'm on Windows 10, and in the snapshot channel. Don't think this has been fixed in a recent snapshot, though, so maybe it's an OS-dependent issue?)


  • Moderator

    @igorgl This thread is about what happens on Windows.


  • Moderator

    @igorgl your post for Linux moved; please continue at https://forum.vivaldi.net/topic/33980/alt-menu-can-not-be-disabled


  • Moderator


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.