How to disable alt menu?



  • Hello!
    I need to disable alt menu because when changing language it always opening -
    Maybe someone know how to disable this.
    PS. I dont want to use horizontal menu!


  • Moderator

    @goncharmarko

    The Alt key on its own focuses the menu, as it does in pretty much all windows programs, even Notepad.

    If your shortcut to switch keyboards includes the Alt key, plus some other key, pressing them both at the same time should work without bringing up the menu.

    What is your shortcut for switching languages?



  • @Pesala "What is your shortcut for switching languages?" - Shift + Alt
    And when i typing that menu always open :(
    And i dont know why, i dont pressing alt...



  • I just tried and pressing shift-alt at the same time quickly and multiple times SOMETIMES it pops up the menu indeed, because done quickly I probably don't sync the presses at the same time, but if done slowly I can't replicate.
    Change the shift alt combo to something else that doesn't include alt key?


  • Moderator

    @goncharmarko Neither Shift+Alt nor Alt+Shift opens the menu.

    The menu opens when you release Alt, not when you press it.



  • For me it open almost every second time. And non of other programs - attention - not make it. So, it is Vivaldi's realisation of alt-menu is bad (as opera's 12). I think, even the same programmers makes it)
    There must be some option in setting to disable this malignant alt-menu.



  • @asires
    I totally agree with you.
    Pretty much all window programs won't take focus by pressing a common IME shortcut like "Alt + `"


  • Moderator

    @yuyu-k The menu in Vivaldi also does not take focus when pressing Alt+ ` or any other combination of keys. For me, it only takes focus when pressing and then releasing the Alt key — just like all other programs. The only problem that I see is the failure of the drop down menus to open when the horizontal menu bar is displayed, if one presses Alt+F, etc. (Then there is the other known issue that cursor keys don't navigate the menus).


    Specs: AMD A10-6800K, 8 Gb on Win 10 64-bit • Snapshot 1.13.1008.19 (64-bit)



  • Lol 111 views...
    Okey @Pesala but i always pressing shift first and i cant do anything with it.



  • Alt-menu appears if you 1. press shift 2. press alt 3. unpress alt 4. unpress shift. And no matter, if between these actions is 1 millisecond. This is bad realisation, alt-menu must not appear, because before it's pressed-unpressed, shift is pressed and must cancel triggering an alt-menu.


  • Moderator

    @asires Please report this issue so we can discuss it internally and investigate to make the menu more user-friendly.


    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug separate at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    If you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bug tracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!




  • @gwen-dragon

    Please fix this.. I'm almost leaving Vivaldi for this. I'm on Linux and it is't true that it happens with all programs, not on Linux. It doesn't happen with the horizontal menu, but I'm not going to use that one...



  • I tried today to use Vivaldi as my main browser, but it is impossible: almost every time when I tried to change the layout/language with alt+shift shortcut, the alt menu was opening.

    I have every popular browser(IE, Chrome, Firefox) installed on my laptop, and Vivaldi is the only one with this bug/future. My laptop is under Windows 10, 64bit

    Please, fix this!



  • @i-petkov @mg979 @goncharmarko
    Did anyone reported this as bug already as Gwen suggested?
    If none of you'll do, this won't get fixed - maybe by accident but that's a bad chance to gamble on.


  • Moderator

    Found a old feature request VB-12686 "Allow disabling or reassiging the keyboard shortcut (Alt) that opens the Vivaldi menu"



  • @gwen-dragon it should be added that menu should react on alt alone, not when shift is pressed, that's what makes the menu appear, lack of fingers coordination. Keep shift pressed and then also tap alt a couple of times. Menu appears/disappears.
    If both are pressed simultaneously, menu doesn't appear.





  • I have the feeling, that I'm the only bilingual human here :( Sorry for the sarcasm , but the problem with the Shift+Alt shortcut and the menu appearing is not annoying... it makes Vivaldi completely unusable for people like me, who use 2 or more layouts/laguages.

    Where is the problem? If I want to change the keyboard layout when I write, the appearance of menu interrupts me almost every time! One video is more than thousand words:

    https://youtu.be/JVHXERS4vEs

    This problem is very old. I can't use Vivaldi as my main browser. It's pain... :( Please fix it! The problem is huge for every person than write a lot and use 2 or more layouts/languages.


  • Moderator

    @kayovas said in How to disable alt menu?:

    I have the feeling, that I'm the only bilingual human here

    You're not.

    I solved the problem of switching keyboard long ago by customising the UK International keyboard using the Microsoft Keyboard Layout Creator. My PagePlus Keyboard can be used to type Pāḷi or English without difficulty, (or the occasional French word if I need to write words like résumé with accents).

    I no longer have to switch keyboards.



  • @pesala said in [How to disable alt menu?]

    I solved the problem of switching keyboard .... My PagePlus Keyboard .

    This is workaround, not complete solution of the problem. I have home desktop computer, laptop and two work machines: an ultrabook and and a workstation. If I want to use Vivaldi on some other laptop/desktop I always have to install this third party app...

    Beside, the Vivaldi is the only browser with this sort of issue!

    The problem is very serious and affects very basic and core functionality: to use two layouts. It's very surprising that this sort of problem is still unsolved... :(

    Regards


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.