Dead Bird Tabs annoy me hard



  • I have fully switched to Vivaldi Browser, cos it's so awesome.
    But those Dead Bird Tabs that happen frequently for me drive me nuts.

    Is there anything I can do to make them not happen?
    Any Logs I can give you people to find out what causing them?

    Using Vivaldi version: 1.12.955.48 (Stable channel) (64-Bit)
    JavaScript: V8 6.1.534.41
    Flash: deactivated
    command prompt: vivaldi.exe --always-authorize-plugins --enable-blink-features=ResizeObserver --flag-switches-begin --disable-accelerated-video-decode --enable-es3-apis --enable-fast-unload --ignore-gpu-blacklist --num-raster-threads=4 --enable-smooth-scrolling --enable-features=AutomaticTabDiscarding,MemoryCoordinator --flag-switches-end


    System Information

         Operating System: Windows 10 Home 64-bit (10.0, Build 16299) (16299.rs3_release.170928-1534)
                 Language: German (Regional Setting: German)
      System Manufacturer: Gigabyte Technology Co., Ltd.
             System Model: AB350-Gaming
                     BIOS: BIOS Date: 09/15/17 14:16:39 Ver: 05.0000C
                Processor: AMD Ryzen 7 1700X Eight-Core Processor          (16 CPUs), ~3.6GHz
                   Memory: 16384MB RAM
      Available OS Memory: 16334MB RAM
                Page File: 5329MB used, 13437MB available
              Windows Dir: C:\WINDOWS
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 96 DPI (100 percent)
       System DPI Setting: 96 DPI (100 percent)
          DWM DPI Scaling: Disabled
                 Miracast: Available, with HDCP
    

    Anything more you need to know?



  • @freeman79 To start, it would help to have some examples of where the "Dead Birds" happen (urls).

    You also don't mention any extensions, have you tried testing with a clean profile?
    https://forum.vivaldi.net/topic/10388/refreshing-or-cleaning-your-profile



  • @tbgbe
    Yes I already tried a clean profile. didn't help anything.
    Most of the time the dird birds happen when I watch twitch streams videos on dailymotion, or vidme.
    I didn't experience them when watching a youtube video.
    For me it looks it happens when a Tab with a video stays open for some time.

    Besides that I noticed tabs with videos use up to 2GB of RAM. Not sure if that's the culprit.



  • Did you try a search for Twitch?



  • @pesala
    yes of course.
    but it's not only twitch. it's a lot of pages for me that show html5 videos.



  • @freeman79 Looking through your posts on
    https://forum.vivaldi.net/topic/21873/dead-bird-tabs-on-twitch-tv/

    I can see that you had "buffering" problems (but no "Dead Bird Tabs") and so turned on "ignore-gpu-blacklist".

    It may be that the Chromium engine really does have problems with your GPU and so there may be no (easy) workaround for both problems.
    ( I hesitate to suggest replace your GPU, what ever it is. Maybe you need to wait for more Driver updates?)



  • @freeman79 I have something similar, but the dead birds came when i'm watching youtube video, thats seams to be caused by some video buffering or something like that.

    Thanks everyone for replying :D



  • My last dead bird was almost half a year ago in a Chrome Experiment (WebGl, I think),. Since then I haven't seen him again.
    Win 7 32 Bits



  • I used to have a lot while watching YT videos, recently they're really rare. I got one last week while watching a 2 hours long video near the end. Closed tab, ctrl-z, it restarted few seconds after the crashed point and not seen again.



  • @tbgbe
    I do use a NVIDIA 1060 GPU from Gigabyte. So I doubt I have to replace it.
    Besides that I have no issues with chrome/firefox or opera browsers.

    About that buffering issues, as you can see in that thread, after I updated to the .48 version these are gone.

    @ian-coog
    Yeah it also happens for me only if I watch long videos/streams.



  • @huntears said in Dead Bird Tabs annoy me hard:

    @freeman79 I have something similar, but the dead birds came when i'm watching youtube video, thats seams to be caused by some video buffering or something like that.

    Thanks everyone for replying :D

    My GPU: NVidia Geforce GTX 1050ti
    Processor: Intel core i5 (And a number that i don't know)k



  • @freeman79 said in Dead Bird Tabs annoy me hard:

    I do use a NVIDIA 1060 GPU from Gigabyte. So I doubt I have to replace it.

    This is strange because from your vivaldi://gpu
    I see "GPU rasterization should only be enabled on NVIDIA and Intel DX11+, and AMD RX-R2 GPUs for now.: 643850
    Disabled Features: gpu_rasterization"

    So it seems you are using different gpu and that it has been blacklisted by chromium.

    Besides that I have no issues with chrome/firefox or opera browsers.

    Even stranger if you do not have same problem with Chrome or Opera (also uses Chromium engine). [Note: firefox is using different engine so not relevant to this issue].

    Vivaldi 1.12.955.48 uses Chromium 61.0.3163.102, is this also true for your Chrome/Opera?

    BTW the Vivaldi 1.13 snapshots use Chromium 62.0.3202.90, have you tried that? (Can test with standalone installation without affecting your stable installation).



  • @tbgbe

    This is strange because from your vivaldi://gpu
    I see "GPU rasterization should only be enabled on NVIDIA and Intel DX11+, and AMD RX-R2 GPUs for now.: 643850
    Disabled Features: gpu_rasterization

    If you refer back to that old post of mine, that was cos I got hardware acceleration disabled back then.
    Meanwhile I turned it on via chrome://settings, but dead birds remain.

    actual output of vivaldi://gpu is:

    Graphics Feature Status
    Canvas: Hardware accelerated
    CheckerImaging: Disabled
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Force enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Hardware accelerated
    Video Decode: Software only. Hardware acceleration disabled
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Disabled
    Driver Bug Workarounds
    clear_uniforms_before_first_program_use
    decode_encode_srgb_for_generatemipmap
    disable_delayed_copy_nv12
    disable_discard_framebuffer
    disable_dxgi_zero_copy_video
    disable_framebuffer_cmaa
    exit_on_context_lost
    force_cube_complete
    scalarize_vec_and_mat_constructor_args
    texsubimage_faster_than_teximage
    Problems Detected
    Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    TexSubImage is faster for full uploads on ANGLE
    Applied Workarounds: texsubimage_faster_than_teximage
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    ANGLE crash on glReadPixels from incomplete cube map texture: 518889
    Applied Workarounds: force_cube_complete
    Framebuffer discarding can hurt performance on non-tilers: 570897
    Applied Workarounds: disable_discard_framebuffer
    Limited enabling of Chromium GL_INTEL_framebuffer_CMAA: 535198
    Applied Workarounds: disable_framebuffer_cmaa
    Zero-copy NV12 video displays incorrect colors on NVIDIA drivers.: 635319
    Applied Workarounds: disable_dxgi_zero_copy_video
    Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
    Decode and Encode before generateMipmap for srgb format textures on Windows: 634519
    Applied Workarounds: decode_encode_srgb_for_generatemipmap
    Delayed copy NV12 displays incorrect colors on NVIDIA drivers.: 728670
    Applied Workarounds: disable_delayed_copy_nv12
    Accelerated video decode has been disabled, either via blacklist, about:flags or the command line.
    Disabled Features: video_decode
    Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers
    WebGL2 has been disabled via blacklist or the command line.
    Disabled Features: webgl2
    Checker-imaging has been disabled via finch trial or the command line.
    Disabled Features: checker_imaging

    Even stranger if you do not have same problem with Chrome or Opera (also uses Chromium engine). [Note: firefox is using different engine so not relevant to this issue].
    Vivaldi 1.12.955.48 uses Chromium 61.0.3163.102, is this also true for your Chrome/Opera?
    BTW the Vivaldi 1.13 snapshots use Chromium 62.0.3202.90, have you tried that? (Can test with standalone installation without affecting your stable installation).

    Yes my chrome uses Chromium 61.0.3163.102

    //EDIT:
    I just noticed, that my chrome detects way less Problems then Vivaldi. in chrome://gpu



  • @freeman79 said in Dead Bird Tabs annoy me hard:

    Graphics Feature Status
    ...
    Video Decode: Software only. Hardware acceleration disabled
    ...
    WebGL2: Disabled

    Accelerated video decode has been disabled, either via blacklist, about:flags or the command line.
    Disabled Features: video_decode
    ...
    WebGL2 has been disabled via blacklist or the command line.
    Disabled Features: webgl2

    These settings are different to mine, but as I only have Nvidia GT 640 yours "should" be better. If it is not blacklisted (you say Chrome works/less problems) then maybe you have different flag settings.

    If you refer back to that old post of mine, that was cos I got hardware acceleration disabled back then.
    Meanwhile I turned it on via chrome://settings, but dead birds remain.

    Try checking your flags again, see Vivaldi Help/About for Command-line settings.

    (Maybe I won't replace my GPU just yet :laughing: ).



  • @tbgbe
    yesterday I disabled "animations" in Vivaldi which was a good step in the right direction as it seems.
    so today I have already set every available flag in Vivaldi same as in Chrome + I use the same command line options I have in chrome with Vivaldi now.

    So far I feel a huge improvement in performance in browsing sites and much less dropped frames when watching online streams.

    So far also no dead bird... But I have only watched a twitch stream for 53minutes atm :D Dead Bird risk usually starts at around 2hours of watching a stream.... So we'll see how that turns out later.





  • nothing helped :(
    Still dead birds.... I have also tried the 1.13 snapshot version and still those dead birds happen for me.



  • How would I log the dead birds so maybe one could have a look what's going on ?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.