*FIXED* Clicking with middle button inop on certain web pages?



  • Can someone try this to see if it's replicable on other computers?

    In Vivaldi (v.1.13.1002.4 64-bit) go to: https://www.thaivisa.com/forum/forum/1-thai-visas-residency-and-work-permits/ ) & run your cursor down, using the middle mouse button to click on links to message threads as you go. How many open in background tabs? For me, less than 1 in 10 (if any) do.

    Now open Edge to the same web page and again middle-click while going down the page. How may open in background tabs? For me, it's all of them.

    Until a couple updates ago, Vivaldi also opened all the links in background tabs with middle-click, but now doesn't.

    Bug, or something unique to my system? :confused:

    (Also, for that web site, several months ago, in Vivaldi I lost the ability to apply formatting to composed posts. e.g. If I compose a reply and try to apply formatting by selecting text and clicking on the B for Bold or I for Italics, nothing happens. In other browsers it works fine.)



  • This bug reported many times:
    https://forum.vivaldi.net/post/169018

    But your link is extreme example of this bug.
    Same for aliexpress site for not working RMB+scroll bug.
    PS: now aliexpress works. Maybe they removed component, conflicting with Vivaldi's bug)



  • @wpcoe

    middle mouse button to click on links to message threads as you go

    Problems with mouse middle click are known issue & already bug reported.

    ability to apply formatting to composed posts.

    I can't help in this category. I can't enter that site to check is part of it.
    From its look though, that "thaivisa" forum seems using same forum framework with Vivaldi forum, NodeBB. Could you use text formatting in this Vivaldi forum?



  • @asires : Thanks. I didn't look at that particular thread as I didn't recall which update it started with. Since there were a couple updates that weren't "auto pushed" I missed a few and skipped right to the latest version.



  • @dleon Thanks. As mentioned, I didn't know just where to look to see what has been reported as a bug. Now I know. :-)

    re: applying formatting while composing posts, yes it does work in this forum, but not on thaivisa.com



  • @wpcoe
    No open bug tracker nor open bug list for Vivaldi.

    Just ask around Vivaldi forum to confirm bugs you find. Usually, either after other users or forum Mods confirm it then you could report it on https://vivaldi.com/bugreport/.
    Or somebody/somepeople already done it like in this mid click issue.

    For thaivisa, if it's really like Vivaldi forum, just try to use;

    • **this's produce bold**
    • *this's produce italics*

    Both formats style are always used in any markdown derivation.



  • @dleon said in Clicking with middle button inop on certain web pages?:

    @wpcoe
    No open bug tracker nor open bug list for Vivaldi.

    Just ask around Vivaldi forum to confirm bugs you find. Usually, either after other users or forum Mods confirm it then you could report it on https://vivaldi.com/bugreport/.
    Or somebody/somepeople already done it like in this mid click issue.

    For thaivisa, if it's really like Vivaldi forum, just try to use;

    • **this's produce bold**
    • *this's produce italics*

    Both formats style are always used in any markdown derivation.

    The thaivisa.com forum software apparently isn't the same as the vivaldi.net forum. Using asterisks and/or slashes doesn't format the text, it only adds asterisks and/or slashes to the reply. My workaround for B, I, and U has been <ctrl+b>, <ctrl+i> and <ctrl+u>. For S I have to surround the text with [s] and [/s] tags. It would be "nice," though, to have the formatting buttons work properly (as they do in other browsers, and used to -- many moons ago -- in Vivaldi.)

    BTW, for those of you with access to bug report lists, has the text-formatting issue which we're discussing been reported? If not, I'll file a bug report.



  • @wpcoe
    Aah, BBcode forum.

    You couldn't find anyone in thaivisa forum to seek info around this issue? Who know, maybe there are other Vivaldi user there.

    Better wait for someone more expert for this.



  • @dleon said in Clicking with middle button inop on certain web pages?:

    @wpcoe
    Aah, BBcode forum.

    You couldn't find anyone in thaivisa forum to seek info around this issue? Who know, maybe there are other Vivaldi user there.

    Better wait for someone more expert for this.

    The "support desk" forum section there isn't all that responsive. I've reported things over the years, and never received much relevant feedback. Since the middle-button and compose-format issues seem specifically Vivaldi related, I figured I'd just post here.

    FYI, both of those issues don't occur using Comodo Dragon, another Chromium-based browser, so it really does seem like they're very much Vivaldi issues.



  • The hits keep coming. As if losing the middle mouse-click to open links in a background tab wasn't enough, when I open links from my e-mail program (Thunderbird), Vivaldi no longer respects the browser window size. Every link I open now forces Vivaldi to full-screen.

    I'm displeased with the tail wagging the dog (Vivaldi dictating my computer usage habits) to the point that I no longer use Vivaldi for most of my browsing. That's sad and Vivaldi used to be an amazing browser, but in the last several months I've seen no usable enhancements, only loss of functionality.


  • Moderator

    @wpcoe Both of these problems are fixed internally.



  • @wpcoe Wait until next 1.13 Snapshot, the bug is fixed.



  • @gwen-dragon said :

    Wait until next 1.13 Snapshot, the bug is fixed.

    is it fixed in 1.13.1008.14? ? Because the changelog doesn't show this smashed bug?



  • May be the fix you need is not in current .14 yet.

    My internal version is >1008 and the bug is fixed there.



  • @gwen-dragon good. I came here hoping to find out whether this was a common issue and if there was a fix, or when such would be provided. I was ready to change my default browser over it. 1.13 snapshots have been much more troublesome for me than previous versions.



  • @geofftaylor said in Clicking with middle button inop on certain web pages?:

    1.13 snapshots have been much more troublesome for me than previous versions.

    Yes, some 1.13 Snapshots are more crashing that the ones before.



  • Hallelujah, clicking with the middle button works again!

    No more using multiple browsers. For now. Until something else breaks?

    The most irritating devolvement now is that Vivaldi opens all links from Mozilla Thunderbird full-screen, rather than windowed as it did in the past. Thunderbird hasn't changed, but the behavior has, so I'm holding Vivaldi responsible.



  • @wpcoe said in *FIXED* Clicking with middle button inop on certain web pages?:

    all links from Mozilla Thunderbird full-screen, rather than windowed as it did in the past.

    Please open a different thread.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.