Win10 x64 1703 to 1709 "upgrade" disaster, x3.



  • Summary Question: Is Win10 1709 a badly broken upgrade, or is there something else wrong here?

    Background:
    Hi. I've been a Linux user for ~3.5 yrs, who left Windows 7 back then. On my 2 Linux PCs now i have a total of 3 Win10 VMs, which i occasionally use just to try to not completely lose touch with Windows. Until ~10-14 days ago, all 3 of these VMs were 1703, & each fully worked [that is, to the extent that Windows could ever be said to work well]. Unfortunately, i made the fateful decision recently to upgrade these to 1709, one by one. After each upgrade was finally complete [including the 3,167 reboots that seem to be needed; gosh i love Linux!], none of the three gave any obvious indication that the process had been anything other than successful. I did not, however, actually bother mucking about with them much at the time.

    Yesterday i needed to install a pgm in one of them that i wanted to test for my father, to make sure it would be ok for him to use on his "real" Win10 pc [which is still 1703]. To my shock the pgm would not install, with Win10 instead throwing an incomprehensible error. At first i thought i had a bad copy of the exe file, despite its checksum being ok, but then i randomly tried to install other pgms, & they all threw the same error. See these example pics:
    0_1509803290461_20171104_003.png
    0_1509803315543_20171104_004.png
    0_1509803366566_20171104_006.png

    Here's what happened when i try to run the already-installed WinAero Tweaker:
    0_1509803339764_20171104_005.png

    Today i discovered that the identical failures occur on both of the other upgraded Win10 1709 VMs. Huh?

    Lots of online research, & lots more experimenting with my VMs, did not provide any solutions. Hence today i chose to take the semi-nuclear option in one of these broken Win10 1709 VMs. I did Settings - Update & Security - Recovery - Reset This PC - Keep My Files. This removed all my pgms, kept my files, then removed Win & installed a fresh copy of 1709. Shockingly, after all the time this took, the supposedly fresh installation was still broken, with the identical problems as before.

    Next i went full nuclear... Settings - Update & Security - Recovery - Reset This PC - Remove Everything. This removed everything altogether then installed a fresh 1709 copy. To my disgust, this also made no difference to the original problem, & indeed now was even worse in that not only were all my pgms gone but so also was the VM's Guest Additions [so now there's no Shared Folders, or proper fullscreen etc, & because of the ongoing fault i now cannot even reinstall Guest Additions]. With this newly virgin 1709, the nature of its failure to install any pgms has slightly changed, ie, different error msg, but the same broad outcome exists... a broken OS that refuses to install any software:

    • "ShellExecuteEx failed; code 3221225477"

    Does anyone have any suggestions pls?



  • Any thirdparty antivirus or other sec progs installed before?

    Try this for repair: https://support.microsoft.com/en-us/help/947821/fix-windows-update-errors-by-using-the-dism-or-system-update-readiness



  • The previous win10 feature upgrade was great. This one... completely borked. It uninstalled all of "UWP" app, and that included system ones. I just reinstalled it from blank and it worked.

    Note: By "reinstalled" I mean I loaded the installer onto a USB and re-formatted. I didn't use the built-in reset function.



  • @LonM The last Windows 10 Fall Creators update was crap. I had to do a clean reinstall.

    @Steffie Try my repair with
    sfc /scannow
    and then DISMs before reinstalling.



  • Perhaps: for the file system errors i read somewhere sound schemes do not work on Windows 10.
    Try disable your user sound scheme.

    But it could be a problem with Windows UAC broken.



  • first error could be about not working VBOX additions in new update.
    Better delaying feature updates ;)
    Within 10 days usually you can go back to 1703.



  • @hadden89 Thats why i use VBox 5.1.30.


  • Moderator

    @steffie I don't use VMs, but I have read a couple places that the 1709 update experience was uneven. I tried to force it early using an insider edition on one of my machines to clean up a registry error, and it wouldn't complete.

    Later, however, it completed on its own on all of my Win10 machines without error, and without visible problems - and that's a lot of Win10 machines. So I don't know how it would differ on a VM, because I don't speak VM.



  • @gwen-dragon Thanks. No. Just a "vanilla" Win10 1703 in the VBox VM; worked fine. Then, after upgrade to 1709... disaster.

    If this was my "real" OS & this happened, i'd be furious. 95% of me wants to just walk away from it now & delete the VM, then never think about crappy Windows ever again. However the less emotive 5% of me says that i should solve this, coz i need to keep Win10 VMs here in my Linux so as to allow me to stay familiar enough with Win10 for me still remotely supporting my elderly dad's Win10 [geez i wish he would let me migrate him to Linux].



  • @lonm OK, interesting... so other people have also experienced crap with 1709, & not just in a VM either? That's good for me to know [i already did assume the problem was 1709 itself & not me, given that my 3 independent good 1703 VMs became broken after their independent upgrades].

    I do not have any dedicated installer. My path to Win10, back whenever it first became available in 2015{?], was the free upgrade from Win7 [by which Win10 was also digitally licenced & activated] for 2 of my VMs, whilst the 3rd was via an Insider's Pgm early ISO that they just kept upgrading & activating for me. Now that all those labyrinthine paths are closed, i can pretty much now only do reinstalls via the nuclear options i earlier described... & as you read, they did not solve the problem.



  • @gwen-dragon Thanks GD, i shall try it shortly & report back here.

    BTW though; i feel very pessimistic about the chances of this solving it. Remember that i also did the semi-nuclear, then later the nuclear, options. Surely either of those should have eliminated any underlying Win10 file-system damage... unless the damage is actually caused by the upgrade process itself...?



  • @gwen-dragon During my research into the problem over the past 2 days i did come across people with an older Win10 version, but otherwise the same symptom as mine, claiming that changing the Win10 Theme's sound to "no sound", solved the problem... but it did not help me. However just typing this now i remembered that [of course] i am running these in a VM, so maybe i also need to look at disabling the VirtualBox sound as well?

    Personally i do suspect that UAC is broken... but i do not know how to prove or repair that.

    EDIT: Nope, disabling sound in the Win10 Theme AND also disabling the VM's sound via its VB Settings, did not help.



  • @hadden89 If i had pre-known that 1709 was going to be so broken, i would have chosen to defer that upgrade for [up to] 365 days per Advanced Settings. Or, if as soon as i had completed the upgrades i had tried to install any new pgm & thus immediately discovered the crappiness, i could have rolled-back to 1703 & all would be good still. Annoyingly however, the 10 day roll-back limit had expired for 2 of my 3 VMs before i discovered that 1709 had this major problem. Only one of my VMs was [only just] still within that 10 days, hence it's the only one i was able to roll-back, & now is the only working Win10 VM i currently have.



  • @gwen-dragon My VBox is also 5.1.30.



  • @ayespy Teehee, an excellent corporatese euphemism;

    the 1709 update experience was uneven
    


  • @steffie Dogdamnit... MS... all the copious invective i have screamed in their direction for 20 years, which ultimately drove me to Linux in Dec 2014, is now front of mind again. I could not even begin on your suggestion, Lilo.

    From https://support.microsoft.com/en-us/help/947821/fix-windows-update-errors-by-using-the-dism-or-system-update-readiness :
    "To resolve this problem, use the inbox Deployment Image Servicing and Management (DISM) tool. Then, install the Windows update or service pack again.
    1. Open an elevated command prompt. To do this, ... if you are using a mouse, point to the lower-right corner of the screen, and then click Search. Type Command Prompt in the Search box, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow."

    But i cannot get administrative rights, that's the whole problem!! When i do this, bloody UAC kicks in & blocks me, again [& of course, w/o admin rights i cannot even change UAC's settings or disable it]:

    0_1509847569959_20171105_001.png

    What a bitter irony... the very fault that has crippled my 1709 VMs is the same fault that then blocks a possible solution to the problem. Great work MS. Grrrrrr.


  • Moderator

    @steffie You can create a new top-level administrator account (it's actually activating an existing hidden one - not creating one). Once you activate it, you can log in as it, which I have done ages ago and forgot how now. You're welcome. (The instructions are on line somewhere). Curious thing about that special account. It cannot run MS Edge. But it can do other magical things.


  • Moderator



  • @ayespy said in Win10 x64 1703 to 1709 "upgrade" disaster, x3.:

    @steffie You can create a new top-level administrator account .

    Thank you, but no, i cannot. The entire thrust of this broken upgrade is that it blocks ALL access to admin privileges. Pls note step #3 in your kindly linked article:

    "3. Right-click on the Command Prompt result (cmd.exe) and select "run as administrator" from the context menu."

    Right there is where it all comes unstuck... run as admin invokes UAC, & UAC misbehaves by responding with those ever-so-helpful error msgs. Here's the one that pops up at Step 3:

    0_1509929557663_fb42b78f-bac6-4072-9992-3f0e36df126a-image.png

    I am just so pleased that Win stopped being my real OS in 2015. Win10 1709 is broken, at least for me [3 of 3 became stuffed by this upgrade]. Onya, Redmond.



  • Yesterday arvo i abandoned my attempts to solve it by myself, given that lotsa research & experimenting over a couple of days had given no progress. Hence i contacted MS via their

    0_1509929961811_373e0b5a-b7a1-4df3-9c5d-7d305b894def-image.png

    link in Settings, & eventually a 2.x hour telecon & remote session ensued. Though very pleasant to deal with, & surprisingly focused on genuinely trying to solve the problem, MS Tech Support also could not get past the admin access impasse; all their magic tricks still implicitly relied on being able to get the elevated privileges. Ha!! They mentioned that the root cause might be that 1709 is not yet supported by VB 5.1.30... but i suspect that was a guess; my research did not unequivocally rule that in or out.

    Once all her efforts to fix 1709 were just as unsuccessful as my own, eventually the tech attempted to download & clean-install a 1703 ISO. Guess what ?[anyone following this thread already knows the answer] - that [ie, the ISO getting & creating bit] was also blocked by the cursed UAC debacle. Ha, again. The call ended with her telling me that my choices now appeared to be:

    1. Get myself to a "real" Windows m/c & repeat her procedure to create a 1703 ISO.
    2. Contact VirtualBox & ask if they can release an update that's compatible with 1709 [ie, she continued with that theory].
    3. Wait... & wait, &... for MS to eventually fix 1709 for VB compatibility, at which point it would be pushed to me via usual Windows Updates.

    After the call was over, i glumly reviewed the command strings she'd attempted on my screen in the command box re getting the ISO, & realised she'd made two typos. I repeated the steps myself with the correct paths, & was pleasantly surprised to observe that now the 1703 ISO creation process initiated & ran... no error!! In time, it finished, still without error. Said ISO file was dutifully inserted in the VM's virtual optical drive with said VM then booted, & a normal 1703 installation process began... ran... finished... & succeeded. All my pgms are gone, of course [but no data was lost, as all that safely resides on my real SSD in my real OS... Linux natch], but now this clean 1703 is fully functional [just like it was before i made that regrettable decision a fortnight ago to allow the 1709 "upgrade"]. Today i'll repeat the process on my other [still broken] 1709 VM.

    Thanks to all here who took an interest & tried to help. :-)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.