TeamViewer extension doesn't work

  • I am trying to use teamviewer extension on vivaldi, the extension installs but when I open it , it says "the chrome native client browser plugin is required to run TeamViewer".
    The story is same also with freeconference, when I try to open it says browser unsupported.
    These kind of issues stops me from using the vivaldi. I don't want to use multiple browsers to do every day task, Will it be possible?

  • @l_sivaram Looks like chrome's native client will be deprecated in Q1 2018. That means you will only be able to use it in Chrome OS.

  • Thanks for the reply, this answers the teamviewer issue, what about the freeconference? It doesn't use any plugin, On opening the window it reports browser not supported.

  • @l_sivaram No idea, you haven't even provided a link to the extension. Your best bet is contacting the extension developer directly. Should have some sort of contact or support link.

  • Thanks again for the reply, I should have been more clearer, The freeconference doesn't use any plugin or extension, It uses normal window, it can be tested from following link,
    It is unsupported in firefox as well. I thought since chrome extensions can be installed in vivaldi, what ever chrome can do vivaldi will also do.
    I have posted a question to the freeconference support also regarding the browser support, let me see what they come back. Its really a pain to use different browsers for different websites/functionality, I just can't avoid installing chrome in the computer which I don't want bcos of data privacy concerns. unfortunately looks like every other browser falls short to google chrome in someway.

  • @l_sivaram Just pick another user agent. You can do this by installing an extension, or by choosing another one in devtools. For me chrome-mac works. The site just doesn't recognise Vivaldi as a chromium browser, but it still works out fine, if you do that.

  • Thanks, It worked, tested in both windows and linux. Changing user agent using extension didn't work, tried 3 of them, It worked when I change the user agent in developer tools. To make it permanent I am passing the user agent as argument to the application. Interestingly team viewer also works now.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.