Cant disable "Broadcast IP for best WebRTC Performance"



  • I'd like to disable WebRTC because it leaks information on my VPN.

    In the privacy settings I cannot disable the "Broadcast IP for best WebRTC Performance". It is check marked and despite clicking it to uncheck mark it does not change. I've restarted my machine and the browser multiple times.

    I am running Windows 7 on VMware.

    I was able to disable on another VMware machine but this time I cannot and I do not know why.



  • Do you run extensions? Some of them could "lock" the rtc status



  • uBlockOrigin or Privacy Badger locks the Vivaldi setting.



  • @canadianleaf Just to visually reinforce the earlier replies fyi, if you do this:

    0_1509633932705_20171103_001.png
    ...then you can do this:

    0_1509633949926_20171103_002.png



  • In the privacy settings I cannot disable the "Broadcast IP for best WebRTC Performance". It is check marked and despite clicking it to uncheck mark it does not change.

    @canadianleaf fail to "uncheck" the setting because it's coming back checked.


    So, almost like @Hadden89 question;

    • Installed & running extensions?
    • 3rd party softwares running? If you do run them in this VM.

    I assume that Win7 environment, not like Roaming, locked environment or something. Because those environments tend to either lock settings or re-install them every new session.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.