Forcing Command Line Switches



  • Good afternoon all,
    I am using the -force-device-scale-factor=1 command line switch on my pinned shortcuts (Desktop, Taskbar, etc.). This works great when using the shortcut; however, if Vivaldi is started w/o using the shortcut, the command line switch (obviously) isn't used.

    Is there a setting or edit somewhere where I can add that option so 1) maybe not need it on the shortcut and 2) it is always applied when the application is run, e.g. from a link, from another program, etc. ?



  • Create a batch file containing said command line switches and link the shortcuts to said batch file instead of original EXE.
    Use something like start Vivaldi.exe -force-device-scale-factor=1 .

    If you require an actual EXE for aesthetic purposes or for pinning, there are utilities out there to convert bat to exe.



  • Thank you for the suggestion; however, that doesn't solve my issue (at least I don't think it will). Here is an example, Vivaldi is set as my default browser through Apps (Windows 10). If Vivaldi is closed and I click a link from my email, Steam, etc., it launches Vivaldi correctly, just not with the command line parameter applied. That's why I wondering if there was a config file where that setting could be added. This way, no matter how Vivaldi was started it would be applied.

    For my workaround, I just copy the link, open Vivaldi and Paste and Go. Due to my monitor setup and DPI scaling, I have to use that command line switch to make everything look nice, crisp and scaled properly.



  • @vongalin said in Forcing Command Line Switches:

    If Vivaldi is closed and I click a link from my email, Steam, etc., it launches Vivaldi correctly, just not with the command line parameter applied.

    !!! On Own Risk !!!
    Open Windows Registry
    Find key HKEY_CLASSES_ROOT\VivaldiHTM\shell\open\command
    Change Value of (Standard) to
    "C:\Program Files\Vivaldi\Application\vivaldi.exe" --force-device-scale-factor=1 -- "%1"



  • @gwen-dragon Thank you for the tip. Slight modification on my end and it is working perfectly ! I had to rearrange the --'s.

    My location and value of (Default) is now :

    HKEY_CLASSES_ROOT\VivaldiHTM.EKF4KPYO7BDPTGHUOXDG4PAY4A\shell\open\command
    "C:\Users\VONGALIN\AppData\Local\Vivaldi\Application\vivaldi.exe" --force-device-scale-factor=1 -- "%1"

    With this setting set, double-clicking a shortcut when V is closed now opens it just as if I had used my shortcut w/the command line entry.
    Thank you again !


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.