Disabling weak ciphers and TLS protocol versions



  • Currently I'm using the following command line switches to disable weak ciphers and TLS versions in chrome. [code] --ssl-version-min=tls1.2 --cipher-suite-blacklist=0xc007,0xc011,0x0066,0xc00c,0xc002,0x0005,0x0004 [/code] Is there something equivalent that can be used with Vivaldi?



  • Confirmed that the above switches work with the Vivaldi x64 1.0.151.7 build for Windows

    Edit the Vivaldi shortcut properties and paste this in the Target field

    "C:\Program Files\Vivaldi\Application\vivaldi.exe" --ssl-version-min=tls1.2 --cipher-suite-blacklist=0xc007,0xc011,0x0066,0xc00c,0xc002,0x0005,0x0004
    

    Launch regedit.exe and edit the http/shell/open/command registry value under HKEY_CLASSES_ROOT and change the (Default) REG_SZ Value to read:

    "C:\Program Files\Vivaldi\Application\vivaldi.exe" --ssl-version-min=tls1.2 --cipher-suite-blacklist=0xc007,0xc011,0x0066,0xc00c,0xc002,0x0005,0x0004 -- "%1"
    

    This will protect you even if you open Vivaldi by clicking a link in an email or other document.

    You can test your browser to see if the switches are working at https://www.ssllabs.com/ssltest/viewMyClient.html



  • Thanks! :)

    You probably already know about these chromium command line switches (many/most of which may work with Vivaldi), but I thought I'd just mention them in case other readers don't.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.