Adobe Flash Player and Extensions

  • I am trying to transfer from Chrome to Vivaldi, but there is one setback which is keeping me on Chrome. I take multiple online courses, and I browse Vimeo and Youtube often. However, whenever I open the content that requires AFP it says the plugin does not load. Support for Adobe would be great, along with extensions because I have about 20 different extensions on Chrome, such as Messenger for Facebook, Adblock, and PanicButton. Thanks for the browser it's awesome!

  • That's odd - if you're using 32-bit Vivaldi I guess make sure you're using 32-bit Flash (and the same goes for 64/64)? If they don't match it might not load flash, even if it says it's installed on your system.

    YouTube works, for the most part. There are some issues with resolution that forums user Case goes over in excellent detail, but if you can live with lower resolution, you should be fine. Vimeo, however, isn't working in Vivaldi - yet.

  • What is the exact error message and/or behavior you get? Flash player should work just fine in Vivaldi, unless there's some other issue.

    For general plugin troubleshooting, check vivaldi://plugins on some info (you can get more by clicking on Details). If you've only been using Chrome so far, it is entirely possible that you actually don't have Flash player plugin installed - Chrome includes its own Flash player (or at least did, I'm not really up to date on Chrome issues, so they might've changed it in the meantime).

    Also, there are two types of Flash player plugin - the older (as in older technology, not version) NPAPI plugin and newer PPAPI one. While it seems like Vivaldi can still work with both of those (and you can indeed have both installed at the same time), installing the latest version of PPAPI Flash plugin should be what you want. You can get it here, just select your system and the plugin version:

    If it doesn't help, tell us what your vivaldi://plugins page says about your Flash player plugin(s).

  • So I figured out the problem- I just needed to select the "always allowed" box, and it worked like a pro. Thanks for the tips!

  • I just had the same issue here, on my PC.
    I have a PC and a Laptop, both 64bit Win8.1 (Pro), both 64bit Vivaldi TP3.

    On the Laptop Flash was working fine (NPAPI version), on the PC NPAPI version just wouldn't load, even when checking always allow. I had to install the PPAPI (aka PepperFlash) version and now it seems to work just fine.

    So anyone having trouble you might want to try this as well.

    The only difference on my Laptop and PC is that the Laptop's Vivaldi is installed on the default path (under AppData), the PC's is installed on D:\Program FIles (custom folder). No idea if that's what caused it and not really time and the mood to test it 😛

  • So… Chrome-plugins work for Vivaldi? Does the Widevine-plugin work too? If so, how do you install it?

  • Moderator

    You go to Chrome Store and click Install

  • @An_dz:

    You go to Chrome Store and click Install

    Yes, it's strange, but true.

    I went there for two other extensions over the past day or so, and both installed fine.

    One is called Simple Tab Order, about which I have already posted in detail in another thread here today, regarding the behaviour of opening and closing tabs, and the other is called uBlock, to block ads, which installed, but the toolbar button is missing, if I can use what I would have seen in the version which I use for recent FireFox as a frame of reference.

    I will just wait and see whether any ads make it thru now.

    = = = = =

    Flash is a different kettle of fish.

    I use the ESR version, and I would suspect that the Vivaldi browser has no idea what that is.

    Its version number is still at 13, which V says is out of date when I click on any content.

    I can do some more clicks to make the video play anyway.

    It's not as important to me as some other issues, but hopefully they will fix it some day.

  • @An_dz:

    You go to Chrome Store and click Install

    Didn't work for me. I still get Error Code: M7355-1203


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.