Disable auto-launch in reboot.



  • If i reboot the system with Vivaldi opened, after the reboot, it launch itself and restore the last session. I don't like this behaviour, how i can disable this feature?

    Note: I know that W10 have a pesty feature relaunching apps after a reboot that cannot be disabled, but is supposed that is only used after an update. With Vivaldi happens with any reboot, not only with reboots caused by updates.


  • Moderator

    @pesanur I have not seen this. There is a mode you can set in flags to make something like this happen. Go to vivaldi://flags and disable "Enable Push API background mode."

    That setting enables background mode for the Push API. It also allows Vivaldi to continue running after the last window is closed, and to launch at OS startup, if the Push API needs it.

    It is supposed to be DISABLED by default when Vivaldi is installed. If you turned it on, that's probably the source of your problem.

    Otherwise, It does not seem to be a normal feature of Vivaldi. If disabling the flag doesn't fix it, it's something else. Is there any extension you might be running that is using the browser code to perform a full-time or periodic task? It occurs to me that some extensions (like an email notifier or something) might actually re-set that flag without your knowledge.



  • @ayespy said in Disable auto-launch in reboot.:

    vivaldi://flags

    It is set to DEFAULT, but i not changed it.
    I not have any extension installed, but I build a new rig a month ago, and clean installed Vivaldi, so maybe this flag is set to DEFAULT instead of to DISABLED in the las version?


  • Moderator

    @pesanur If it's starting with Windows, you need to set it to Disabled. Again, YOU might not have changed it, but some extensions can.



  • I changed it to disabled and now isn't longer self starting when I restart de computer, thanks for the tip, but I insist in that I'm not installed any extensión and that is a clean install (I only make a backup of the bookmarks, but not of the profile), so something have been changed in the last version.


  • Moderator

    @pesanur said in Disable auto-launch in reboot.:

    something have been changed in the last version.

    Hm. Not on any of my machines here.



  • I think that i discovered whats happened, after installing Vivaldi, I deleted an entry in the registry under HKCU\SOFTWARE\Microsoft\Windows\RunOnce, looks like deleting this entry activated Vivaldi relaunching itself when the computer is shut down or restarted without closing the browser before. After changing the flag, the entry was re-added, and Vivaldi not longer restart itself.



  • Not have any more problems with this until today, that Vivaldi started to self-launch again if I reboot the system (update reboot) without closing the browser first. The flag is disabled, but is ignored.

    Edit: Vivaldi added again itself the next registry string to self-launch and restore session after reboot:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce]
    "Application Restart #1"="C:\Users\Pedro\AppData\Local\Vivaldi\Application\vivaldi.exe --always-authorize-plugins --enable-blink-features=ResizeObserver --flag-switches-begin --disable-push-api-background-mode --enable-features=password-import-export --flag-switches-end --restore-last-session"

    Exist any easy way to permanently turn off this without the need of to be deleting the entry after each Vivaldi update?


  • Moderator

    @pesanur That's completely weird. Vivaldi is not written to do this. None of my systems auto-launch Vivaldi. Ever.



  • My Vivaldi does too after updating to build 17133 of windows 10 pro.


  • Vivaldi Translator



  • @sojiro84 said in Disable auto-launch in reboot.:

    @pesanur it is a windows thing.

    For a fix, see this: https://superuser.com/questions/1229963/windows-10-disable-reopening-programs-after-restart-startup

    This might help.

    Yes I know, if you take a look in the first post of the thread, I'm already said it.

    But a Win32 app need to specifically support this feature, and yes, Google put this support in Chromiun, and appears that Vivaldi not removed it or at least give us and easy way to disable it.

    Note: The option to avoid the reopening in the Windows settings, isn't working in the FCU. Is a know bug that MS have left unsolved until the next major update.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.