Vivaldi not prompting for certificate authentication any more

  • I have several certificates on smartcards that I use for various websites. Recently, Vivaldi doesn't prompt for a certificate any more when I try to visit a website that needs one to log in, which means I can't use it for those websites. The smartcards work just fine in Firefox and Internet Explorer.

    Currently running Vivaldi 1.13.971.8 x64.

  • Moderator

    The 1.13 has a new Chromium/62.x code base. Perhaps that is the problem.

    Just curious: with which Vivaldi version did a prompt for a certificate smartcard worked?

  • I'm not sure when it stopped working, but it was fairly recently. I've been using Vivaldi for a few years now, and didn't have any problems accessing sites that require certificate authentication.

  • Moderator

    Please report the serious bug. Smartcard PKI is important.

    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    If you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!

  • @ender85: Did you file a bug report? I had the same issue for some time. Now Vivaldi asks but login to sites requiring smartcard authentication simply do not login. I'm asked for authentication in a loop.

  • I did file a bug report, VB-34267. As of 1.13.1008.21 there's no change regarding smartcard authentication - the prompt simply never appears.

  • @ender85 It's interesting that we see a different behaviour. BTW did you test what was the last version that worked? I'm thinking about rolling back until this is fixed.

  • Moderator

    @ender85 said in Vivaldi not prompting for certificate authentication any more:


    Would be good to know in which version when it worked before!

  • I'm not sure when it stopped working - it definitely still worked on 1.11.917.43, which I had on my laptop that I rarely use, and therefore wasn't updated.

  • Sorry, @Gwen-Dragon, I also don't know which version was the first when it stopped working. I can only test it at work and unfortunately I don't have the time to install earlier versions to test.
    The current version (1.14.1064.3 32 bit) still does not work. I tested it in chrome (Version 63.0.3239.132 64 bit) and there it works like a charm.

  • Have you tried to access the web page that requires a certificate from a private window?
    I had an experience where Vivaldi would take the wrong action automatically, probably because I told it so, and not prompt me. The private window did not remember what I instructed it to do, and prompted me for instructions instead.
    Even if this works, it's just a workaround; then you'd need to teach Vivaldi to stop doing the wrong thing in non-private windows...

  • I just wanted to let you all know that this issue was caused by cookies that interfered. I deleted some cookies and now it works. I'm sorry I blamed vivaldi for that 😞


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.