web links open in non-default (i.e., non-Vivaldi) browser



  • I have Vivaldi set as my default browser, but the web links I've saved on the desktop, my documents, and elsewhere open in my non-default browser. I've tried right click > open with > choose default browser, but Vivaldi is nowhere to be found in recommended programs or other programs, nor anywhere in any of my program files after clicking the browse button in order to try and find it. Suggestions? Many thanks.



  • Is Vivaldi installed for all users, for a single user, or stand-alone? Stand-alone should not effect the registry, which would mean it isn't listed as a program that can handle "web links".



  • Ok, so I've figured out where the vivaldi exe is located (C:\Users\User\AppData\Local\Vivaldi\Application), and set it as my default. Icon next to saved web links is now the vivaldi icon, but when I open it, rather than the actual web page I get what you see in the attached pic.

    @sgunhouse My administer account is the only account on the computer, so only a single user. When I installed it, though, I apparently didn't pay that much attn to the specs and can't remember whether I selected stand-alone or not. Is there any info anywhere that would tell me if I did? Perhaps the fact that the path to the exe leads to a local file means I did? If so, I suppose the best thing to do would be to uninstall the stand alone and install the other?

    0_1508639793715_69ed9d01-c45c-489d-923d-7ecafd1af61c.png


  • Moderator

    @hryan My internal test version is installed standalone and it is also set as the default browser (and works a such). So perhaps the way to approach this is to go into the Windows Control Panel and assign the version you have installed as default for all file types and all protocols.


  • Moderator

    @hryan I notice, however, that the file extension is ".url" It's an internal file, clearly, but perhaps it should be using a different extension. On the other hand, although it is an internal file, it is referencing a video that is stored on the web. Can you tell us anything about how you came to be trying to access this file with Vivaldi?



  • @ayespy Originally found the web page with embedded video via google search. When opened directly from search results, and when url is pasted into browser url bar, it opens the page as it should as seen in the attached. I then wanted to save the page for quick and easy reference. I selected the url in the url bar, clicked and held the site icon to the left of the url, then dragged and dropped to my desktop. When links were still opening in my non-default browser, clicking the desktop shortcut took you the page as it should as seen in the attached. Once I changed to Vivaldi as the default per my earlier description (Vivaldi was already set as the default in control panel), clicking the desktop shortcut took me to the vivaldi page that only shows file location as seen in the previous image.

    0_1508643307649_e1646121-9bd0-4272-8529-3599e92a8795.png


  • Moderator

    @hryan I see. What's the original URL to the page on the web, so I can do some testing?


  • Moderator

    @hryan I found it on the web. I began to play the video and dragged the address bar icon to my desktop. I double-clicked on the resulting link on the desktop and was taken by Vivaldi straight to the video, which began to play. Are you quite sure you have set Vivalidi to be default for every web file type and protocol by going into the Default Programs section of Control panel, selecting Set your Default Programs, going to Set Defaults by App, selecting Vivaldi and then checking off every file type and protocol?



  • @ayespy https://www.spine-health.com/video/degenerative-spondylolisthesis-video

    FYI, all other link shortcuts I've created are having the same problem too, not just the one above.


  • Moderator

    @hryan Something wrong with your system, or with extensions you are using, or something. Please read the MOST recent reply I posted.


  • Moderator

    @hryan As nearly as I can tell, your system should NOT be appending ".url" to dragged and dropped links. Please delete the file extension and see what happens.



  • @ayespy I've never known drag and drop web shortcuts to be anything but .url (other than, perhaps, shortcuts from IE, which I never use). Even so, deleting the file extension renders it to a non-working file of unspecified type other than the properties saying "File". I've also tried changing the file extension to .html and .htm to no avail.

    In all of this I've discovered there are number of places where the default browser can be set. I've made sure Vivaldi is set as the default in all locations. In addition, I've forced a file-type association between Vivaldi and as many other file types as possible that were previously default-associated with other browsers. Lastly, just to see if it would make any difference, I: uninstalled the other browser I had been using (Maxthon) which I no longer plan on using now that I've found Vivaldi; and, uninstalled and re-installed Vivaldi, this time installing for all users rather than single user, which placed Vivaldi files under Program Files (x86) rather than in Users\User\AppData\Local as it had done with a single-user installation.

    After all of the above, web link shortcuts I've created still don't open the actual web page. I've also discovered that web links in documents will default open in Vivaldi, but clicking it doesn't automatically switch me over the the browser window. Rather, after clicking the link in the document I have to then switch over to Vivaldi myself, where I find the page from the link I clicked opened.



  • @ayespy Oy. Though perhaps at reinstall I should have done stand-alone since that's been working for you without incident. Maybe I'll try that tomorrow.

    BTW, other than for troubleshooting purposes, is there any reason a stand-alone installation would be the preferred installation type if I have no need to put it on other machines sans download?


  • Moderator

    @hryan I have four versions on my machine - so three of them have to be standalone. That is all.


  • Moderator

    @hryan Links (which is what is supposed to be formed by drag-and-drop) do not have file extensions. How you are getting .url on the desktop and how/why any other browser would/should be able to negotiate it, is a mystery to me.


  • Moderator

    @hryan Let me ask you this: What version of Windows are you using, and on what sort of device?



  • @ayespy said in web links open in non-default (i.e., non-Vivaldi) browser:

    @hryan Links (which is what is supposed to be formed by drag-and-drop) do not have file extensions.

    Of course they have and the correct extension is indeed .url
    The system only applies an override to not show them. No, you can't set that in the folder preferences in the Explorer, you need to delete some keys in the registry to see them.

    How you are getting .url on the desktop and how/why any other browser would/should be able to negotiate it, is a mystery to me.

    Probably the following keys were deleted in the Registry (they have no value by by default but must be there to make shortcuts work and to hide the .url extension):

    [HKEY_CLASSES_ROOT\InternetShortcut]
    "NeverShowExt"=""
    "IsShortcut"=""
    

    Other than that: the file:/// stuff should only happen if Vivaldi is not correctly set as default browser. The same goes for any chromium based browser because of:
    https://bugs.chromium.org/p/chromium/issues/detail?id=114871


  • Moderator

    @quhno I see. Here's what I have come up with, digging around more in this. Clicking on the shortcut opens it in the default Vivaldi browser. However, dragging it to ANY desktop shortcut for any Chromium-based browser gives the result OP has reported. However, dragging it to Firefox or IE opens the web page. I haven't tried it using a link created by dragging from some other browser.



  • @ayespy Normally the extension is hidden, but all "web link" files actually do have an extension of .url (that is how Windows knows they are web links). In Presto days, a web link could be set to open with the default or with Opera, there was a separate setting for HTTP and HTTPS urls which the system would follow (versus mailto, FTP or whatever other types of URLs the file might contain).

    In Windows 10 Control Panel, go to Apps then Default Apps, click on Choose default apps by protocol (at the bottom), then make sure V is set as default for HTTP, HTTPS and FTP. On my system, when I go under Choose application by file type, .URL files are set to "Internet Browser" (and not any specific browser I have installed, which would be every browser other than Chrome),


  • Moderator

    @sgunhouse My system is already working right - EXCEPT it appears dragging links to Chromium-based browsers does not open them, though the same links dragged to Mozilla or MS browsers, do open.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.