Web developer extension page Chris Pederick always launches on startup

  • Since version .5 of the Web Developer Extension the splash screen comes up when launching Vivaldi. I know version .49 got hacked and pulled and can understand that Chris wants to inform the users what's going on. But how do I get rid of this screen when launching Vivaldi. It's quite irritating. I have set my startup page to vivaldi://startpage and the page should not be there.

  • Moderator

    The Chris Pederick page comes up if the extension has got an update. But not on other circumstances as i can see on my 1.12 and 1.13 Vivaldis.

  • I don't understand what you are trying to say?

  • I can understand it is useful to open a window after an update, but open every time after launch? There should be a way to disable this for me or not. I can't see a cookie which are alle deleted on quit.

  • Moderator

    @detlevski I can not reproduce your problem on Vivaldi 1.12 and and 1.13.

    Try this:
    Remove the extension
    Open Tools → Clear Private Data
    At Delete Data for: select "All Time"
    Select only "Cache"
    Hit "Clear Browsing Data"
    Restart Vivaldi
    Reinstall the extension from http://chrispederick.com/work/web-developer/download/chrome/

  • @gwen-dragon

    That's what I did, same thing again. Next to Ghostery and the Fair Adblocker I am using Cookie to delete and manage the cookies I do want to keep. There is a setting "Never remove Browser Extension", I will investigate this further as I think Cookie is causing this.

    I am sure it is not a Vivaldi issue and thank you for figuring out where it is coming from, it is irritating no more no less. I start Vivaldi once a day up and it stays open. Love Vivaldi, if only the video playback on the mac was improved it would be nicest browsing experience on the mac.

  • It was indeed resolved by disabling Cookie for Vivaldi, since the last Cookie update DashLane was also giving login errors. So I guess I am looking for another way to dump my cookies on quit.

  • @detlevski
    Let get me straight 1st.
    Your important Cookies/Local Storages (for extension) got deleted, and you want to keep them.

    Why not use Chromium own Cookies/Local Storages feature?

    1st, clear all your cookies/local storages before setting all of these. For some reasons, older data before this set not deleted.
    Except for vivaldi.*, the other Allow are for cookies used by extensions.

    By default they all calling home to check what's new.
    As far, for me, it's only LastPass & Grammarly create cookies/local storage every session to really work.
    How to check this;

    • Clear old cookies/local storages.
    • Don't yet set that "Keep local data only bla bla bla".
    • Exit Chromium-based. Restart after some time (really give them some time).
    • You'll likely to find some cookies/local storages other than for Google in cookies pages. Whitelist all needed.

    Oh, btw, don't worry if anyone thinks my screenshot breach my privacy. It's cleared from old data & my settings really only that.

    Credit: uMatrix has auto cookies/local storage features, and it advises to whitelist site cookies extensions use.

    Only opinion;
    Maybe only happen to me, but all GChrome extensions for "Auto delete" cookies/local storage never work right even for GChrome.

  • @dleon You are right, it was not a cookie thing, but a localStorage "problem", didn't think of that because the Web Dev Extension uses the leveldb name, did not see the connection. And yes the leveldb localStorage got deleted and so the splash screen was opened again. Added this localStorage db to my favourites in Cookie and no more splash screen.

    I know I can set prefs per site, I have disabled JS on more sites, but allowing/blocking cookies on a per site basis is too much of a hassle for me. In Cookie I can add favourites and have all other cookies AND localStorage items deleted on quit or per set interval, the latter I don't use. Everything that is not a favourite gets deleted, cookies and localStorage.

    Yesterday I disabled Cookie in Vivaldi and installed Vanilla Cookie Manager, which works fine in deleting cooking but doesn't delete localStorage db's. The good thing about Cookie is that it works in all my browsers, Vivaldi is my favourite but I use other browsers as well and can set global favourites.

  • @detlevski
    Cool, you found the root of the issue.

    Vanilla Cookie Manager quiet old, 2014.
    There's a newer alternative for GChrome, Cookie AutoDelete.

    Have the same issue with Vanilla Cookie Manager, that's couldn't auto delete local storage. Which it seems you use that drawback to your advantage. Firefox WE version available.

  • @dleon Thank you for your information about Cookie AutoDelete.
    I was exactly trying to find out this kind of add on and this seems to be nice.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.