Serious issue with Vivaldi Cache & History



  • Hi.
    About a year ago I installed Vivaldi and after some hours working with it, I realized that it deletes cache automatically and it has no option for it! (Save Browsing History seems useless!)
    That's why I got back to my last browser (Cent).
    In the last year, everytime Vivaldi new version was released, I tried it but with NO change of cache options!
    Now I want to report this issue.
    Vivaldi has a long-time issue with the "Last Session Start Up".
    When I have some tabs open and I close and reopen Vivaldi, the tabs are GONE! the browsing history either! and the Speed Dials Preview either!
    Now, I have searched A LOT in this forum for these issues and NO LUCK!
    Please, if you are going to fix these issues soon, tell us.
    And if not, I better stick to my Latest Browser.
    Thanks In Advance!



  • I can't reproduce this and never had this problem before. Do you use any extensions?



  • @mau
    Hi. I use lots of extensions:
    Auto Copy
    Chromium Wheel Smooth Scroller
    Clear Downloads
    Copy All Urls
    Disable HTML5 Autoplay
    Don't track me Google
    Fair AdBlocker
    IDM Integration Module
    IP Domain Country Flag
    JavaScript Popup Blocker
    LastPass: Free Password Manager
    NoCountryRedirect (NCR)
    Pure URL
    Quick QR Code Generator
    Redirect Bypasser
    Save Image to Downloads
    SearchPreview
    Session Buddy
    SimpleExtManager
    SimpleUndoClose
    uBlock Origin
    UltraSurf Security, Privacy & Unblock VPN
    Video Autoplay Blocker by Robert Sulkowski
    Video Downloader Pro
    X-notifier (for Gmail™,Hotmail,Yahoo,AOL...)



  • @aliniceboy Can you try to disable all of them and see if the behaviour persists?



  • @mau
    I will try and report the result later.
    Thanks.



  • @aliniceboy
    Start ViValdi in safe mode by shift clicking on the Vivaldi browser icon
    This will put you in safe mode and disable all extensions/add-ons
    Then you can track down the offender(s)

    Worked for me for WaterFox :)

    Report back here with you results please so others can confirm this works.

    Sincerely,
    StarDream



  • @stardream
    Thank you, StarDream.
    I will do it and report the results later.



  • @aliniceboy
    You are most Welcome & Very Glad to be of Assistance
    I eagerly await what I an sure is a positive result



  • @stardream
    Hi.
    After disabling all extensions and working with the browser to make more cache and history, when I closed and reopened it, AGAIN everything was GONE!
    Any suggestions?



  • I use many of the same add-ons (extensions) but two jump out at me as possibly causing your problem: Clear Downloads and UltraSurf Security, Privacy & Unblock VPN.
    Either or both may delete your cache/history as a they may consider saving these as a privacy/security issue.
    The download clearing extension may be able to be "Disabled to help but from what I remember of UltraSurf it is (was) a stand alone programme so it may need to be uninstalled.
    Also from the UltraSurf web site:
    "Ultrasurf hides your IP address, clears browsing history, cookies, and more."
    I delete cache/history at the end of every session as a matter of course, so we sit on opposite sides of the coin but I can understand your frustrations as there are times when researching a topic that I Do want to keep history until I've finished my project.

    Hope this helps



  • @greybeard
    Hi.
    Before Vivaldi I was using Cent Browser and I had all these extensions installed on it, but nothing like these issues (Cache & History Automatic Deletion) happened!
    But, maybe these 2 extensions have some issues on Vivaldi. Because of that I will try your method and after some hours browsing I will report the result.
    Thank you for your response.



  • @aliniceboy

    best of luck



  • @greybeard
    Hi again.
    After some hours browsing, when I shut down my PC and then start it and open Vivaldi, AGAIN everything was GONE!
    Returning back to Cent Browser...
    Thank you for your suggestions.


  • Moderator

    @aliniceboy disabling extensions does not always prevent their effect on the browser. You probably need to REMOVE them and reinstall one at a time until you find what is doing it.

    The solution is to refresh your profile in all likelihood.

    Remember, Vivaldi is immature. And because its architecture is different from ALL other "chromium" browsers, extensions may not work - or may cause problems. The key, in vivaldi terms, is to have options built in - not relying on extensions that consume memory and processor cycles, were not written with Vivaldi in mind, may contain security hazards, and are written/maintained by hundreds or thousands of authors with whom Vivaldi has no influence. Better to do it yourself than to rely on an unpredictable contractor.



  • @ayespy
    Hi. I will remove all of the extensions and see if that changes anything.
    Thank you for your solution.
    I will report the result.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.