Odd "Glitches" appearing sometimes when browsing



  • 0_1508000866411_Captura 10-14-17 at 01.58 PM.PNG

    When I'm using the browser normally on any website, sometimes the interface looks like it's bugging, displaying some types of graphical glitches that disappear only after page reload! Above you can see an example of what appears!

    All my equipment is new yet, I make constant checks in the softwares and hardware, all the drivers are updated with the latest stable updates!

    If it is useful, here are my graphical settings:

    GPU: AMD Sapphire Nitro+ 8gb 256bit with Lastest Stable Driver
    Intel core i5 6500 6th generation


  • Moderator

    @tchelows Can't reproduce this. Do you run any extensions or add-ons for Vivaldi or Windows?



  • Try to deactivate onboard Intel GPU in BIOS.



  • @ayespy said in Odd "Glitches" appearing sometimes when browsing:

    Do you run any extensions or add-ons for Vivaldi or Windows?

    I use only "Emoji Keyboard", "Enhancer for Youtube", "F.B Purity", a translator by google and ublock origin. i know, you want that i disable one by one extension to see which is causing the problem or not.

    @gwen-dragon said in Odd "Glitches" appearing sometimes when browsing:

    Try to deactivate onboard Intel GPU in BIOS.

    Already deactivated.



  • @tchelows said in Odd "Glitches" appearing sometimes when browsing:

    @ayespy said in Odd "Glitches" appearing sometimes when browsing:

    Do you run any extensions or add-ons for Vivaldi or Windows?

    I use only "Emoji Keyboard", "Enhancer for Youtube", "F.B Purity", a translator by google and ublock origin. i know, you want that i disable one by one extension to see which is causing the problem or not.
    ...

    Actually, it sometimes helps "cut to the chase" more readily if you first disable all the extensions to see if the problem clears up. That tells you if the extensions are even involved. If things clear up that way, then re-enable them one at a time to see which one triggers the problem.



  • Same issue, it's been happening since I updated to Vivaldi 1.12.955.38. No new extensions, no new addons, same graphics driver as the previous Vivaldi version. Only extension installed is Ad Block.
    The glitches don't show up when hardware acceleration is disabled, but with it disabled there are slowdowns in things like Google Maps. With hardware accelerations active there are also issues with youtube videos running in 720p or higher resolution stuttering in video, audio still works fine, if another window is in focus instead of the Youtube video.
    Running a Radeon RX 480, driver version 17.7.2 on Windows 10 64 bit 10.0.15063.

    It also happens in pages at times:

    0_1508072450781_error2.jpg



  • Having the same artifacts on my windows machine since latest vivaldi update.

    Win10 64bit Radeon RX 570
    Tried some now AMD-Drivers but they didn't fix that issue. So got back to WHQL-Version 17.7.2



  • I've had similar issues but usually its restricted to within the browser UI. It happens when the mouse previews other windows on the taskbar sometimes. I suspect its being caused by hardware acceleration (the same issue and resolution is found in Firefox) as it also manifests itself by hiding my mouse. However i've not been able to find Vivaldi's option to disable it as the setting seems to have been removed from the settings?

    For some reason most browsers on the market just go crazy when you enable hardware acceleration. Which is why its usually disabled by default (or at least it used to be).


  • Moderator

    @dccxviii chrome://settings and then search "hardware."



  • @ayespy Thanks for that. I've disabled it now.



  • In addiction, it only happens inside the browser. nothing exposed here happens outside of Vivaldi. I will try disabling HA by now, but devs should take a look at this!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.