Inconsistent behaviour when opening downloads



  • Hi

    I wonder if anyone else has seen this inconsistency before.

    I have the same version of Vivaldi (1.12.955.38) installed both on my home computer running Windows 7 Pro x64, and on my office computer running Windows 10 Pro x64. In both installations, the Downloads tab of the settings are configured the same way. Most importantly, I set it to always ask for the location to download files to.

    When I click a download link and choose the "Open" option on my Win7 computer, Vivaldi does what I expect it to: it immediately downloads the file to the standard download folder and opens it. This is the same behaviour as pretty much every other browser's out there. However, when I do the same on my Win10 computer, Vivaldi will still open the "Save as" dialogue and ask me for a location to save the file. Once I've done that and the file is downloaded, Vivaldi does open it – but I don't think it should be asking for a location beforehand. That seems to run against the idea of offering an option to "Open" directly.

    I'm interested in why I see this inconsistency between two installations of the same version of Vivaldi, but I'm also interested in finding a way to get my Win10 installation to behave like my Win7 installation does.

    Any hints appreciated :smiley:



  • I think you must have a different option selected in Settings, Downloads. Here, "Open" does what it says, and saves the file in the Downloads folder without asking. I have notifications enabled, and always save files disabled so that the dialogue with the Open button is displayed.



  • @pesala said in Inconsistent behaviour when opening downloads:

    I think you must have a different option selected in Settings, Downloads.

    The settings are exactly the same in both installations. Always saving to standard download folder unchecked, automatically opening download panel and notifying on complete downloads checked. Even the default download folder is set to the same location, the Downloads subfolder in the user home directory.

    I even tried toggling the options. When the standard download location is activated, I don't even get the download dialogue on either installation. When I toggle it back off, the behaviour of both browsers is different again.


  • Moderator

    @anamon I suspect it's merely a difference between the structure of Win7 (which I almost never fire up - but will test in two days when I have access to it again) and Win10. One will open any file that you say to open no matter where it is downloaded to, and the other that will open such files ONLY if they are downloaded to Temp, and not to your (for instance) Downloads or Desktop directory locations. Vivaldi does not, by default, download anything to Temp as several other browsers do.



  • @ayespy Thank you for your reply! I'm not sure I fully understand though. The difference in this behaviour is happening before the actual OS call to open the file is invoked, isn't it?

    On both my Windows 7 and Windows 10 installations of Vivaldi, the default download directory is set to "C:\Users\<username>\Downloads". I just checked and that is, in fact, where my W7 Vivaldi downloads files to that I choose to directly "Open", as opposed to a Temp directory.

    But on Windows 10, Vivaldi asks me for a download location right after clicking "Open". Going by @Pesala's reply, the behaviour of every other browser, and in fact your reply as well, I shouldn't be asked that question. The decision on whether to download the file to the default download directory or ask me for a location is Vivaldi's, not Windows'.


  • Moderator

    @anamon You may have the settings set differently on your two versions of Windows. There is a Vivaldi setting to "always" download to default location. If you have that unchecked, it will always ask you instead.



  • @ayespy Sorry, but that is not the difference. As I have mentioned in posts #1 and #3, the Downloads section of the Vivaldi settings are completely identical in both installations. Checkbox 1 disabled, checkboxes 2 and 3 enabled.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.