Slow performance issue



  • Hello,

    I'm a new convert to the Vivaldi browser and really like some of it's features. I have some problems with the performance though, it's pretty laggy. I've turned off several features like animations, tab preview, accent colors, gestures etc. with no change.

    I'm on an ASUS Zenbook Pro UX501VW with Intel Quad Core i7-6700HQ 2.6GHz, 16GB DDR4, SSD, Nvidia GTX 960M etc. so my computer shouldn't be the problem, and Chrome, FireFox, Brave and Opera has been running just fine (I tested a few before I ended up going with Vivaldi), so I'm not sure what the problem is.

    It pretty much makes it unusable for me. When I move my mouse over bookmarks it takes a second before it's highlighted, when I type, the text appears a second after being typed, tabs open a second after I've clicked new tab, scrolling is slow, everything is just really unresponsive. And sometimes the whole browser just freezes, everything is registered, but it doesn't respond. So when it freezes I can close a tab with ctrl + w, but nothing happens, when I then press for instance alt + tab, or ctrl + alt + del, the tab closes.

    I've checked the task manager and the cpu/memory seems to be fine, it's really weird. Basically all I've done since installing it is to import bookmarks, add two extensions (tried to disable these to see if that solved the issue without luck) and added a few webpanels.

    It wasn't like this to begin with though. It seemed to happen after I tried out the tile function where I had an pdf next to webpages. This was really slow and it seemed to carry over to the rest of the browser, haha. I pretty much set up everything in the beginning, so I haven't made any changes that could've caused this to happen. I've tried to clear all data, restarted the computer etc, but the low performance continues.

    Any ideas before I try to re-install the whole browser?

    Thanks!


  • Moderator

    @mibo What happens if you refresh your profile?



  • Hi, it is also possible a antivirus software block Vivaldi.
    Several user report about and disable is not enough, you have to uninstall it.
    Avast, Eset and some other I cant remember.

    Cheers, mib


  • Moderator

    @mibo And, BTW, re-installing is almost never an answer. It's 99.999% of the time in the profile or some external factor. Bad installs essentially never (well, almost never) happen.



  • I didn't touch anything, didn't make any changes, I just went out for a couple of hours, and when I got back home it was suddenly not sluggish anymore. So I tried to surf around a little bit and after I had visited a few websites it went back to being sluggish again. So annoying!

    I don't use any antivirus software other than what's in Windows 10.

    I tried what you said Ayespy, closed Vivaldi, renamed the default folder, and re-opened. Same problem.
    It's like Vivaldi is running at 10 FPS or something.



  • Here's a screen-recording so you can see what I mean with laggy/sluggish:
    https://www.dropbox.com/s/4kq509eulpu04mz/Slow performance issue _ Vivaldi Forum 03-Oct-17 15_48_24.mp4?dl=0


  • Moderator

    @mibo All weird stuff. I've not seen any of that. I wonder if the update has caught an incompatibility with your graphics card or something?



  • I have a pretty mainstream graphics card though.
    Now it works again. I'll see if I can figure out what's causing it.



  • I had the freezing problem happen in another browser now, so that's not Vivaldi's fault at least. Maybe I just need to reinstall Windows -_-


  • Moderator

    @mibo FIRST, try enabling or disabling your graphics card in the various browsers. "Mainstream" is not an actual value in this regard. "Recognized by Chromium and not blacklisted" is kind of the only thing that counts.



  • I discovered that the freezing is not specific to Vivaldi, it happens in Chrome and Brave too. The browsers freeze, but inputs are registered, all I need to do is to mouse over the taskbar and the window unfreezes and everything that was registered during the freeze happens at once.

    I tried to update the graphics driver, but the problem persisted. I'll try to disable it now and see if that changes anything, thank you!



  • I tried to disable the graphics card in the device manager, that didn't solve anything. Also tried to disable everything in the system start up, that didn't solve it either. I think I'll just uninstall all browsers and re-install. Getting a bit desperate about solving this issue now.



  • Uninstalled all browsers, re-installed Vivaldi, same problem.
    Re-installed Brave, same problem.
    Microsoft Edge and Explorer however, works just fine. No lag or freezing or anything.

    Any other suggestions?



  • Tried in safe mode and the issue is gone, tried to clean boot and the issue is back.

    If I go to the task manager and choose always on top and just tuck the window down in the corner, everything is fine. As soon as the browser is on top, it'll start to lag and freeze :expressionless:



  • I gave up and just re-installed Windows, that fixed it!
    One last question: Why is the 32bit version of Vivaldi automatically downloaded when I'm on a 64bit system?


  • Moderator

    @mibo You can go to the download page and get the 64-bit one. I don't know why you are not offered the choice right out of the box, but I do know that the download server does not detect which Windows you have - and the 32-bit runs on all systems from Win7 on up, so perhaps it's just the simplest way to do it right now.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.