Glitchy display after a short while



  • I'm not sure whether it's caused by update to 1.13 or HighSierra but since about two days Vivaldi on macOS is very annoying to use - after a short while there are numerous display glitches (both in parts of webpage as well UI).

    Anyone else experiencing the same?


  • Moderator

    How does such issue look like?



  • @gwen-dragon said in Glitchy display after a short while:

    How does such issue look like?

    Terrible ;-)

    But jokes aside:
    https://www.dropbox.com/s/up6k2d9dmz3odrt/Captura de pantalla 2017-09-30 19.35.28.png?dl=0
    https://www.dropbox.com/s/k06ib5fo9h05w1z/Captura de pantalla 2017-09-30 19.35.40.png?dl=0

    Same page, after reload it went back to normal more or less (clicking on some elements wasn't working every time so I had to repeat it a couple of times).

    <rant>I soooo looove the SPA and web "applications"</rant>


  • Moderator

    Perhaps your graphics card's hardware acceleration causes this.

    Try this:
    Open chrome://settings/system in address field
    Switch off Use hardware acceleration when available
    Restart Vivaldi



  • @gwen-dragon said in Glitchy display after a short while:

    Perhaps your graphics card's hardware acceleration causes this.

    That seems like a plausible cause.

    Try this:
    Open chrome://settings/system in address field
    Switch off Use hardware acceleration when available
    Restart Vivaldi

    Wouldn't this cause the slowdown? web is currently bloated so having the aid of hardware acceleration is a huge benefit.

    The idea of the thread was to check if anyone else had same issue and/or bug was reported (and I now I could do it and also possibly submit some more details/logs).

    For now I've disabled the acceleration and will see if it helps...


  • Moderator

    @wojtek said in Glitchy display after a short while:

    Wouldn't this cause the slowdown? web is currently bloated so having the aid of hardware acceleration is a huge benefit.

    Yes, i know. But the fact is that some users have problems with their Macs if hardware acceleration is active.

    Hmm, perhaps it is a problem of GPU vsync.
    On Linux i solved such by starting Vivaldi from a shortcut with
    vivaldi --disable-gpu-vsync and/or --disable-software-rasterizer
    But that may depend on display server which is different on MacOS and Linuxes.
    I apologize, i am not a Mac user, i try to check what could help you. :angel:


  • Moderator

    @wojtek It's really hard to say what's happening in your case. High Sierra is still very new. Vivaldi was tested on pre-release betas but it can take time to shake out and fix problems with all sites and with all hardware combinations.

    Both Vivaldi updates last week also included a change to the underlying Chromium code, so that too could potentially be the cause.

    What version of Vivaldi are you using? Have you tried testing with your extensions disabled? Are you primarily experiencing problems only with this particular site/app or all web sites?

    Are you a Chrome user and if so, are you running into any issues with that browser?



  • @gwen-dragon said in Glitchy display after a short while:

    @wojtek said in Glitchy display after a short while:

    Wouldn't this cause the slowdown? web is currently bloated so having the aid of hardware acceleration is a huge benefit.

    Yes, i know. But the fact is that some users have problems with their Macs if hardware acceleration is active.

    Hmm, perhaps it is a problem of GPU vsync.
    On Linux i solved such by starting Vivaldi from a shortcut with
    vivaldi --disable-gpu-vsync and/or --disable-software-rasterizer
    But that may depend on display server which is different on MacOS and Linuxes.
    I apologize, i am not a Mac user, i try to check what could help you. :angel:

    So far so good so I'll test software sync more. Also - starting apps with command line parameters on mac is a bit of a hassle (supprisingly even windows is better in that area :sigh:)

    Thanks for the feedback and suggestions ^__^"

    @xyzzy said in Glitchy display after a short while:

    What version of Vivaldi are you using?

    I'm using 1.13.971.8 (Build oficial) (64 bits) exactly

    Have you tried testing with your extensions disabled?

    Not yet, and as this also (sometimes) results in glitches in whole UI display I would say it's more of rendering problem altogether (as UI is also in html/css/js) and extensions should interact with it

    Are you primarily experiencing problems only with this particular site/app or all web sites?

    No, this happens randomly. I've noticed that mostly after Vivaldi was running for a while (couple of hours, I usually don't quit browser and it runs all the time)

    Are you a Chrome user and if so, are you running into any issues with that browser?

    No, I don't user Chrome (only Opera for short testings, which is based on same engine). I migrated to Vivaldi from Firefox and chosen Vivaldi as the "lesser evil" (not really fond of having anything related to chrome or google altogether; would be awesome if Vivaldi migrated to servo <3 but I've read Jon's statement and understand the choice...)


  • Moderator

    @wojtek Thanks for the update and best of luck with your troubleshooting.

    My general advice for Mac users running into glitches is to ensure that all vivaldi://flags are reset to default and to then be VERY selective when enabling any flags. Windows and Linux systems have virtually infinite hardware variations so changing flags is often required to work around issues with some configurations; Macs variations are limited and changing flags from their defaults often cause more problems than they solve.

    I totally respect your choice not to use Chrome.

    FYI... Like most users, I run Vivaldi with extensions and my preferred settings. I also have a Mac with a blacklisted GPU so I currently have to override the blacklist in order to enable playback of some media types. When I encounter problems, I have an alternate Vivaldi installation (with defaults and no extensions) for testing. If things still don't work, I try with a Chrome stable release to check whether the problem is with Vivaldi or the Chromium base code. I also test with Safari (or Firefox) to check for problems that might be specific to the web site.



  • Well, I haven't even know about vivaldi://flags :D So I have everything default there. I've only made a couple of changes via the settings UI and added a couple of extensions and that's it.

    For now, without hardware acceleration it seems to be working ok...


  • Moderator

    @gwen-dragon said in Glitchy display after a short while:

    vivaldi --disable-gpu-vsync and/or --disable-software-rasterizer

    vivaldi --disable-gpu-vsync --disable-software-rasterizer

    Did you try this before? Did not help?


  • Moderator

    @wojtek Thanks. Looks like there may be an incompatibility between the Chromium GPU acceleration code and a new graphics driver in High Sierra.

    If you should need to re-enable hardware acceleration, the one other thing you can do is to check vivaldi://gpu to see if any problems get reported there.



  • I've re-enabled hardware acceleration a while back with the desire to catch some logs, but vivaldi://gpu only shows a lot of:

    Log Messages
    [34736:775:1001/172348.742348:INFO:propmedia_gpu_channel.cc(99)] : PROPMEDIA(GPU) : AllowHardwareDecode : Hardware Decode Not Enabled
    [34736:775:1001/172350.296262:INFO:propmedia_gpu_channel.cc(99)] : PROPMEDIA(GPU) : AllowHardwareDecode : Hardware Decode Not Enabled
    [34736:775:1001/172353.435981:INFO:propmedia_gpu_channel.cc(99)] : PROPMEDIA(GPU) : AllowHardwareDecode : Hardware Decode Not Enabled
    [34736:775:1001/172356.854471:INFO:propmedia_gpu_channel.cc(99)] : PROPMEDIA(GPU) : AllowHardwareDecode : Hardware Decode Not Enabled
    [34736:775:1001/172401.625805:INFO:propmedia_gpu_channel.cc(99)] : PROPMEDIA(GPU) : AllowHardwareDecode : Hardware Decode Not Enabled
    


  • OK, so in the end I went back to 1.12 stable. Being on beta doesn't bring that much benefit and on stable everything works just fine... (also - video playback wasn't working on some videos without acceleration)


  • Moderator

    @wojtek Could you please report this as a bug and a potential regression?

    https://vivaldi.com/bugreport/

    Vivaldi 1.12 (Stable) and Vivaldi 1.13 (Snapshot) are currently based on the same Chromium code so this glitch was likely (directly or indirectly) caused by a change in Vivaldi's code.

    Thanks.



  • @xyzzy said in Glitchy display after a short while:

    @wojtek Could you please report this as a bug and a potential regression?

    https://vivaldi.com/bugreport/

    Vivaldi 1.12 (Stable) and Vivaldi 1.13 (Snapshot) are currently based on the same Chromium code so this glitch was likely (directly or indirectly) caused by a change in Vivaldi's code.

    Thanks.

    Reported

    FUN! Obviously after reporting it the problem started with 1.12 as well... FML (or rather 'beloved' chromium...)


  • Moderator

    @wojtek Have you tried disabling all extensions and then selectively re-enabling them?

    Sometimes just disabling an extension is not enough. I would delete any extensions that could affect/customize/break Vivaldi's web-based UI.

    Popular/well-tested extensions like uBlock Origin should not be contributing to your display glitches.



  • Well, I just experienced something similar in Fx, and after a quick chat with a friend (owning same MBP model) it turned out that sometimes he has similar display problems in Safari after upgrading to HS... I would guess there is some problem with HS and hardware acceleration..


  • Moderator

    @wojtek Thanks for the update. Hopefully it's just a software glitch that will be fixed soon.



  • I run into information that this may be related to the introduction of Metal 2... fingers crossed that they will fix that soonish...


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.