Accept-Language / language of sites visited



  • Usually, browsers send out the Accept-Language HTTP header to let sites know which language the user prefers. This is used by much more sites than I thought, I found out after installing and using Vivaldi. Most sites I normally get in Dutch, are now displayed in English. It doesn't matter if I set Vivaldi to Dutch or English, that just changes the UI language. Am I overlooking the Accept-Language setting somewhere or is this setting just not yet implemented in Vivaldi? Or is there a config file I can manually change in the mean time?



  • Just installed the latest snapshot and this hasn't changed yet.
    Any way to expedite this feature, because this basically makes Vivaldi unusable for me as a daily browser. It turns out there are quite a lot of sites using this to detect the language the visitor wants.


  • Moderator

    Right click a text area in a webpage or Vivaldi UI, like the address bar, and go to Spell-checker->Language settings. Or open this page vivaldi://chrome/settings/languages
    The languages you choose here and their orders will be the ones used in Accept-language.



  • Thanks, that works perfectly!



  • In the language settings page, there's no "set language as default" button as other chrome or chrome base browser, and the "ordering language by drag" is not functional.

    This is extremely important for some i18N products, such as IBM portal, which shows the corresponding page based on client's language settings.

    P.S.: I'm using Vivaldi 1.0 for Linux.


  • Moderator

    The userinterface of Vivaldi needs some more feature, we know.

    Workaround: you may start Vivaldi (just as Chromium) with the commandline parameter like –lang=en_GB or which you need from shell or a desktop shortcut.



  • @Gwen-Dragon:

    The userinterface of Vivaldi needs some more feature, we know.

    Workaround: you may start Vivaldi (just as Chromium) with the commandline parameter like –lang=en_GB or which you need from shell or a desktop shortcut.

    Seems not work as I use the option as –lang=zh_CN, any idea?


  • Moderator

    Sorry, my fault. Does not work on Linux. :blush:
    But it is fixed in current internal version.

    I hope, language switching will come in next Vivaldi Snapshot.



  • Bumping this topic, because this two years old issue is still not fixed in Vivaldi 1.8. It still sends the languages from the spell checking settings out as preferred languages inside the HTTP Accept-Language header.

    Even feature-less ChrOpera now has a setting for setting prefered website languages including the option to remove all of them (thus removing the Accept-Language header entirely, which is my preferred setting).



  • @jtsn For me it seems to use the UI language settings, not the spell checking ones. Besides, I'm afraid that bumping this (or any other) topic won't change the state of things, as the developers are usually too busy to read each and every post on the forums - you should rather use the official Feature Request thread or the Bug Report form if you want to make sure, that they'll read your request.

    Also, keep in mind that comparing two years old browser with a twenty+ years old browser will not make your opinion any stronger... 😉


  • Moderator

    Please don't send a bug report about this!
    A non-implemented feature is not a bug.

    And such switching of language for HTTP header independent from UI language setting will be implemented as it is on the devs ToDo list.



  • @Gwen-Dragon Hmmm, but I've seen some users wiser than me, repeatedly asking people to send feature request using the bug report form, so I don't know whose example should I follow - yours or theirs? 😜


  • Moderator

    @pafflick Yes, a feature request is ok over bugtracker, i wanted to say that a missing feature is not a bug.

    We get many bug reports which are not bugs but users think this are bugs because they miss something in Vivaldi seeing in other browsers (sorry about my crappy english here, i have heavy migraine today).



  • @Gwen-Dragon Yeah, I get your point, don't worry about it. 😉

    Here's a little doggy to cheer you up! 😃

    Gute Besserung!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.