Lagging, stalling, & freezing when any tab loading



  • Since updated to latest stable version (full installation), Vivaldi have become very poor in performance. Most serious problem is loading a tab will sometimes lag, or unresponsive to any mouse & keyboard command until the tab is done loaded.

    Then if i open multiple tabs in background at once, Vivaldi will definitely freeze for awhile (over a minute). And sometimes multiple extensions would crashed in the process. OS win 8.1, 8GB.

    I would like to know if anyone have the same problem before i made bug report on this problem. Thanks.


  • Moderator

    @dude99

    Not seen here.

    Various kinds of 3rd party security software have been seen to interpret Vivaldi's intake of Chromium 61 as a foreign and supicious app, and have interfered with all operations. That's one possibility.

    But the first and often best diagnostic action with a sudden performance decline is to refresh your profile.



  • @dude99

    I have this as well since 1.12. Refreshing profile did not resolve. If you have multiple tabs open and any of them refresh data for any reason, it will freeze the other tabs until that data refresh is done, but the refresh itself seems lagged. Doesn't happen every time for me.

    Fresh install did not help. Issue does not present itself in other browsers, but they have their own other issues which is why I use Vivaldi.

    Operating System: Windows 10 Pro 64-bit (10.0, Build 15063) (15063.rs2_release.170317-1834)
    Vivaldi 1.12.955.36 (Stable channel) (32-bit)
    Revision 28aecd4e55a46bdcdab31db8bc95b4fba6c8a36c-
    OS Windows
    JavaScript V8 6.1.534.37
    Flash 27.0.0.130

    Will try disabling Kaspersky, see if that has any effect. *edit

    Edit 2:

    Disabling Kaspersky had no effect. I experimented with trying to duplicate it and capture Youtube link of example below. After the community tabs load and I thought it passed, but I couldn't scroll up on the following tab until it suddenly did it.

    https://youtu.be/AYJ0BY3zU4M

    Edit 4: Apparently there was copyright audio in the twitch stream that I couldn't hear on my speakers. Audio removed and re-uploaded.

    Edit 3:

    Lastly, reverting back to 1.11.917.43 resolves the issue, for me.



  • Thanks for the feedback guys.

    Video playback causing poor performance, freeze, & lagging is known problem for a long time. Not sure why it's not yet fixed. Anyway, this thread problem is focus on loading or reloading tab causing poor performance.

    Thanks thaeral for further investigation, i have also try fresh install & profile reset, but it seems to be the browser problem. I don't use any antivirus software active protection, only do ondemand scan from time to time.

    My concern is hardware acceleration, anyone know if vivaldi is having problem with nvidia? I have setup High performance NVIDIA processor, instead of Default integrated to handle vivaldi.

    Anyone else have this problem?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.