[Fixed] Google Maps is sluggish



  • After 1.12 Google Maps now moves really slow. It has a new button I've never seen before, and don't see on Chrome that asks if I want to switch to Lite mode. That speeds things up, but it means losing Notifications, Places, and Timeline.

    Opera 47, Brave 0.18, Firefox 55, and Cliqz 1.15 work the same as Chrome

    Wondering if this is more of Google putting the screws to Vivaldi.



  • @omen_20 Do you have hardware acceleration turned on? That can help speed things up. Unfortunately, it's not in the vivaldi settings, but you can access it by going to chrome://settings and searching for "use hardware acceleration".

    If it's already turned on, you could try turning it off, just ton the off-chance that might help.



  • In my experience, is sluggish in all browsers (Chrome included), the same thing it´s happening with the search page. I think it´s a google thing. As for screws, I would not be surprised, because the same thing happened to opera years ago.



  • I cant reproduce sluggishness on GMaps with 1.2 Stable on my NVidia GT710 @ Windows 10 x64.

    Depends on graphics drivers and Windows. And i remember the W10 Creators Update produced issues with some graphics cards and CPUs.



  • @gwen-dragon said in [Bug] Google Maps is sluggish:

    I cant reproduce sluggishness on GMaps with 1.2 Stable on my NVidia GT710 @ Windows 10 x64.

    Depends on graphics drivers and Windows. And i remember the W10 Creators Update produced issues with some graphics cards and CPUs.

    I just tried it and it works with fluidity, even satellite view and streetview
    Vivaldi recently updated 1.12 on a paleolithic laptop 10 years, Windows 7 32bits.

    I think it may also be due to some extension, for example a scriptblocker that on some pages can also cause a slow or faulty load, if certain sites are blocked and Google has many hooked to their services.



  • Appears to be working fine now with full Maps. I updated yesterday to 1.12.955.38 (Stable channel) (32-bit). Hardware acceleration wasn't needed, but I turned it on anyway. In the past I'd turned it off to fix a bug, but can't remember what it was. I'll go forward with it on.



  • @lonm My HW acceleration was already turned off. Turning it ON fixed the problem. The maps are lightning fast again.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.