Colors displaying incorrectly



  • For some reason Vivaldi seems to be displaying colours incorrectly, When compared with Opera (or any other browser), the colours in Vivaldi seem to be muted. I've looked through the settings, and I can't find anything that might be causing this. I'm currently using the 1.13 beta, but the situation is the same in 1.12.

    Screenshot below of Opera (left) vs Vivaldi; Colours are correct in Opera... ...am I missing something

    0_1506076369584_Vivaldi-vs-Opera.jpg



  • Can you please give me the URL to the image?

    Looks like Vivaldi uses wrong color profile (or graphics card uses wrong color lookup table).
    Perhaps this helps:
    Open vivaldi://flags/#enable-color-correct-rendering
    Set to Disable
    Restart Vivaldi



  • @gwen-dragon In my case after disable Color correct rendering works right. Thanks.



  • Hi Gwen, and Lachky
    Thank you both for you replies - apologies for not responding sooner, but have been rather busy.

    Gwen - the #enable-color-correct-rendering was indeed the issue. Disabling this has fixed the problem. Interestingly, this is also the case in Opera, and Chrome (all based on Chromium of course). Essentially the colour displayed in with this setting enabled is actually wrong. I've I take a colour sample from the web page displayed in the browser, it is very different from the colour set in the css of the website.

    Many thanks again for your feedback - much appreciated.



  • Perhaps the color correction code in such Chromium-like browsers is not really tested enough.
    But the workaround of disabling the flag solved it always.



  • I switched to Vivaldi 1.13 just few days ago, before I still use older version (1.9.818.50) because all newer versions don't work with my Wacom tablet properly. But I find how to fix this problem, so now I start using Vivaldi beta again. In version 1.9.818.50 the colors are correct also without disable vivaldi://flags/#enable-color-correct-rendering. (I am Windows user with Adobe RGB profile)



  • @gwen-dragon said in Colors displaying incorrectly:

    Can you please give me the URL to the image?

    Looks like Vivaldi uses wrong color profile (or graphics card uses wrong color lookup table).
    Perhaps this helps:
    Open vivaldi://flags/#enable-color-correct-rendering
    Set to Disable
    Restart Vivaldi

    (ED: sorry, just saw this is the Mac forum, don't know whether this affects the Mac version the same way as it does my Linux version).
    With 1.13.1008.32 (stable Linux) the flag is gone and I get wrong colors whith my graphic adapter again. Forcing chrome://flags/#force-color-profile to sRGB seems to fix the issue for me.

    Greetz
    AR



  • With 1.13.1008 Vivaldi became terribly unsaturated. Screenshot attached.
    I wanted to check #enable-color-correct-rendering option, but it is not available anymore.
    Also I tried #force-color-profile option, but it has very little effect and doesn't solve issue at all.

    Dear developers, I really count on you fixing it!
    Thank you.

    0_1512323219000_scrshot1.jpg



  • @edsm

    Hi, I am using 1.14.1030.3 (beta), Win10 with Adobe RGB and in my case the option works well.

    0_1512325996779_47513b73-c57a-4261-a604-072fb7adc0fd.jpg



  • @edsm Which profile did you set with vivaldi://flags#force-color-profile



  • I was wrong, #force-color-profile option actually did help. I have chosen sRGB profile and now everything looks as before. Sorry for confusing.

    I conclude that #enable-color-correct-rendering is superceded by #force-color-profile. The only issue is that "Default" value of the first is not identical to "Default" of the latter.



  • Thanks!

    Switching chrome://flags/#force-color-profile to sRGB, solved the color issue for me too. Hope they don't tinker with it again..

    Oh, and I'm using Windows 10.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.