Syntax error does not install on Ubuntu 16.04



  • Whatever I try to install this I get this error message on two lines and that's it.

    ./vivaldi-stable_1.11.917.43-1_amd64.deb: line 1: syntax error near unexpected token `newline'

    ./vivaldi-stable_1.11.917.43-1_amd64.deb: line 1: `!<arch>'

    Never seen that before, what could that be?

    Thanks
    Andy



  • @andyvoice //EDIT:
    Oh, now i see that you tried to start the file like this:
    ./vivaldi-stable_1.11.917.43-1_amd64.deb
    You cant install a .deb packages file by opening in them in the shell as they are not executable.

    next time try it like this:

    sudo su
    wget https://downloads.vivaldi.com/stable/vivaldi-stable_1.11.917.43-1_amd64.deb
    dpkg -i https://downloads.vivaldi.com/stable/vivaldi-stable_1.11.917.43-1_amd64.deb
    


  • @andyvoice .deb files are not executable files exactly in the way that Windows installers are. You should be able to install it by double clicking the file from the file browser, or sudo apt install <path/to/vivaldi.deb>.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.