[Bug?] restarting Vivaldi causes pages to be zoomed in



  • Win7 Pro PC with Vivaldi v1.11.917.43 (Stable channel) (32-bit). Dual monitors on an old nVidia 9800GTX. Text size in OS still at 100% - no scaling going on there.

    I always leave dozens of pages open in Vivaldi when I close it. Often in the middle of different batches of research. Next day, when I open it up again I usually find the pages have been zoomed up in size. To 110% \ 150% \ 210%.

    Not had time to look closely at the pattern of this. I think some pages get double zoomed when left open longer.

    Weird thing is only the last few pages on the right seem to be affected. Very old pages not touched in a while seem to stay at 100%.

    Is anyone else experiencing this?


  • Moderator

    @mallen - Nope.

    Are you sure you have not changed any of your default zoom or tab zoom settings in the settings menu?

    And what happens if you refresh your profile?



  • Yes, I also have that problem (for a few versions now, don't know when it started). I also have dual screen, no scaling.
    I'm not sure how to reproduce this. Zoom levels are usually 140% or 160%, with the latest Vivaldi version it seems to have changed to 150%, but I'm not sure.
    I also have the feeling it happens on specific domains, I often witness it at heise.de and metal-archives.com.
    A few weeks ago I submitted it to the bug tracker under VB-30707, but I think the problem is too fuzzy to be addressed properly.


  • Moderator

    @hughmongoose Same questions as I asked the prior user apply to you.



  • Hi,
    I have a backup now which has the problem all the time and could narrow the problem down to "Preferences" file.
    And no, all zoom sliders in the settings are at 100%.

    For testing purposes I set them to 110% - the specific tab is still zoomed to 150% on restart. And I opened several other tabs from that domain ( https://heise.de ), and upon restart all were zoomed to 150%, but none of the other tabs.



  • I removed "www.heise.de":2.223901085741545, from Preferences' "per_host_zoom_levels":{ section before starting. That caused the zoom level to be correctly at 100%. Now the interesting question is how the value got in there in the first place.



  • Perhaps a look in internal page chrome://settings/content/zoomLevels?search=zoom helps.



  • @gwen-dragon
    Thank you. The value for heise.de is indeed 150% in there. Interestingly, other pages in the list with odd values are not affected. When I visit them they are displayed on 100%, also when I leave their tabs open and restart.

    Do you know how and under which circumstances these values are added to Preferences file, and how they should be used? For me, the behaviour seems more or less random.



  • @hughmongoose said in [Bug?] restarting Vivaldi causes pages to be zoomed in:

    Do you know how and under which circumstances these values are added to Preferences file, and how they should be used?

    No, sorry. I do not use the Zoom feature.

    Myself beeing a :older_woman: >50 increased the minimal fontsize for webpages to have better reading experience.



  • Weird - I am the OP but didn't get any email notifications from this post.

    Thanks for the replies. And thanks for HughMongoose having the same issues.

    No, I didn't reset my profile. Don't really have the time to retune it all which is why I'll try to avoid that route if possible.

    Yes, I am sure the windows were closed at 100%. It is often very obvious as it is the page visible on top of the stack that is being zoomed.

    I often have 20-50 pages left open when I close Vivaldi. So re-opening brings that heap back again. And that is when it really stands out that a page that was 100% has now jumped.

    I have looked at chrome://settings/content/zoomLevels?search=zoom as suggested and find all kinds pages in there. Don't think these are the specific ones that have had the issue. For a start I have now emptied everything out from that list and will start watching this again.

    And again sorry for not coming back to this thread... I gonna have to dig into the profile to see why I am not getting email replies.



  • @mallen Change your email settings. I think you won't get one if a reply arrives while you're logged in. The Bell icon at top right shows your notifications.

    0_1506970420180_Email Settings.png



  • @pesala Thanks. That was the missing tick - "Send an email when replies are made to topics I am subscribed to"

    I setup the account four years ago, and since then the profile settings have changed a lot. So I guess the inverted setting slipped in during that time.

    What is a little odd is the box at the bottom of the page does say "watching". All fixed now.



  • @mallen said in [Bug?] restarting Vivaldi causes pages to be zoomed in:

    What is a little odd is the box at the bottom of the page does say "watching".

    That adds a notification to the Bell icon, it does not send an email.



  • @pesala The Bell icon? Ah - I think this is probably the problem. This is a forum for people who visit a lot. I wish I had the spare time like back in the Opera days. I'm more used to forums that call me back in to read stuff that has been responded to.

    (No need to explain any more - I understand what is going on now. I'll go dig deeper in all the settings an update everything possible. I don't want to drag this thread off course... even if I was the OP... hehe.)

    Quick edit to add that I now get those notifications after hitting that switch



  • @mallen No mails? Currently there is a problem on vivaldi.net. See https://forum.vivaldi.net/post/164621



  • @gwen-dragon I now have emails. It was just the odd settings in my profile - as spotted by Pesala. I am now getting notifications since ticking the tick.

    The profile was "odd" as it also showed that I was set to get "weekly digest" - which also didn't appear. So my assumption is a confused\corrupted\out-dated profile. Now I have been in and kicked all the switches around and hit SAVE it is behaving correctly and lots of notifications are appearing.

    Thanks to you both.



  • I have the feeling it may be some half-deprecated feature. After clearing the "chrome://settings/content/zoomLevels?search=zoom"-list, everything works fine, and no new entries appeared. And neither zooming a tab nor closing it or Vivaldi in zoomed state adds a site to the list (of course only one tab of that specific domain open for the test).
    Ergo propable solution: Clearing the zoom level list may solve the issue forever.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.