Bug? Open three windows in Vivaldi get problem



  • I'm a new user of Vivaldi, but i get a problem cannot solve.
    When I open three windows in Vivaldi, If I get back to first windows and open a start page,
    the third one will always on top and block me.Then I cannot go back to the first one until I minimize the third one.
    I tried a several version of Vivaldi but useless, hope the official can solve this bug in the next version.



  • I cant reprodeuce this with Vivaldi 1.11.917.43 Stable on WIndwos 10x64.

    I can switch to next window with taskbar or Win+Tab.



  • @gwen-dragon said in Bug? Open three windows in Vivaldi get problem:

    I cant reprodeuce this with Vivaldi 1.11.917.43 Stable on WIndwos 10x64.

    I can switch to next window with taskbar or Win+Tab.

    I recorded a video for this
    https://youtu.be/XJ0pmNxdaKE
    I don't know why I get this bug....



  • That's really strange, I can't reproduce it either, the tabs clicked on the main window get focused, and the new window is never brought back in foreground.
    I see you have an Adblock active. Try disabling it, in tools/extensions. Maybe it's that particular extension interfering. I use uBlock origin, in case you find yours is interfering, you might want to try it.



  • I tried to disable adblock or reinstall the browser but it still happened.
    Then,I try the several older version of Vivaldi to test it.
    Finally I found the version 1.5.658.56.x64 would not appear that bug.
    The others newer version can't solve it.
    That means I can't update the newer version if I don't want to get this problem...


  • Moderator

    @tieas what happens if you refresh your profile?

    Also, do you use any apps that are aimed at modifying your WINDOWS user interface? Like adding context menu options, changing toolbars, etc?



  • @ayespy
    No, I don't install any apps or software to change my Windows interface. Just use default interface.
    I haven't seen this bug on others browser like Firefox, Chrome, Opera or Edge. So that make me very confused.


  • Moderator

    @tieas The architecture of Vivaldi is different from other browsers - so different things can happen. But I'm on Win10 X64 and don't experience your problem, so it's not a Vivaldi+Windows thing. It's a Vivaldi+Windows+unknown co-factor thing, so what's needed is to figure out whate else might be affecting your experience. Did you try refreshing your profile as I suggested?



  • @ayespy
    Yes, I refreshed my profile but useless.
    I'm on Win10 X64 too. I also tried to turn off my background programs on Windows like anti-virus, printer software, keybroad and mouse program, etc. But had the same result.
    Only use old version Vivaldi can fix it.



  • @Tieas Does this happen if you have no other Windows programs started?
    Is see program with a asian character icon in taskbar. May be it is a translation tool or input helper.



  • @gwen-dragon
    Oh, thank you for you prompt.
    I found the reason. It is because of the Chinese input method.
    When I changed the English input method to open the new windows, it wasn't happen!

    But I come from Hong Kong, always change the input method is inconvenient.
    Let me find what method can fix it better. Thanks anyway.



  • @tieas said in Bug? Open three windows in Vivaldi get problem:

    I found the reason. It is because of the Chinese input method.

    May be a bug with Vivaldi.


    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    If you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!




  • Bug is reproduced internally.

    I fear it is a specific Chromium bug. See bug 683801



  • @gwen-dragon
    You're right.
    I tested in my chrome, it had the same problem.



  • @tieas Then you have unfortunately to wait until Chromium version 61 fixes the bug. Vivaldi team has not enough spare time, i guess.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.