Vivaldi for mac's copy function does not work correctly.



  • Vivaldi for mac OS is not implemented the copy feature correctly.
    In several scenes, copied texts in Vivaldi's windows are not copied correctly.

    The very clear evidence of this Vivaldi malfunctions is that Vivaldi does not show the service menu in its contextual menu when texts is copied from web contents in Vivaldi's window, while the service menu appear correctly if you copy texts in the search field in the top of a Vivaldi's window.

    The service menu feature and the copy function is very very basic function. Especially, we cannot allow any modern window systems without the copy function that it functions between every applications.

    After you copy the texts in the search field, the service menu appear when you copy the texts in web contents. But, it does not mean Vivaldi work fine. Just, the copied text from search field is being kept inside mac OS, and if you choose a function from service menu, it uses text from search field, not text from web contents.

    This fact shows that Vivaldi malfunction clearly.

    So, I beg the Vivaldi mac team that you implement appropriately the copy function in Vivaldi for mac as soon as possible.



  • @hana2017 - - - - -
    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    If you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!



Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.