Vivaldi-beta repo: package signature?



  • Hi all, I'm on openSUSE and recently, every time an update for vivaldi-snapshot is out, I get a warning that the package is not signed.

    I have this repo confgured: http://repo.vivaldi.com/archive/rpm/x86_64

    Is this correct? Has anything changed recently?

    TIA
    Cris



  • @Cris70 Hi. My V repo in oS TW is http://repo.vivaldi.com/snapshot/rpm/x86_64/

    Download the V key here: http://repo.vivaldi.com/snapshot/
    Whilst it can be done via terminal too [duh], i tend to revert to the YaST GUI for this; launch YaST2, navigate to Repositories, navigate to GPG Keys, import your downloaded key via "Add".

    After this, anytime you run your sudo zypper dup, your V Repo will be included in the updates, & with the signed key now imported, all should go smoothly for you, as it does with me.

    BTW, isn't oS TW great, & TW + V just a superb combo??!! :-) What DE do you use?



  • @Cris70 The RPM in repo is not signed?


    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    If you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!




  • @Gwen-Dragon thank you for your reply. I can report the bug, but first I'd like to know which is the correct repo. Is it mine, or the one posted by @Steffie ?

    I did a quick search in the forums and I find a lot of variations of the repo URL...
    Which is the official repo for vivaldi-snapshot?



  • @Steffie said in Vivaldi-beta repo: package signature?:

    BTW, isn't oS TW great, & TW + V just a superb combo??!! :-) What DE do you use?

    Hi @Steffie ! You're absolutely correct, TW + V is a really great combo!!
    I'm using KDE Plasma 5.

    Cris



  • @Cris70 I think rpm need to add http://repo.vivaldi.com/snapshot/



  • @Gwen-Dragon I updated my repo list to point to the URL you gave me (btw I think archive is a symlink to snapshot or the other way around because they seem identical).

    Upon refreshing my repos, I got this:

    cristiano@xmper8q3 [~/Downloads]$ LANG=C sudo zypper ref
    Repository 'Insync' is up to date.
    Repository 'Visual Studio Code' is up to date.
    Repository 'home:colomboem' is up to date.
    Repository 'packman' is up to date.
    Repository 'repo-debug' is up to date.
    Repository 'repo-non-oss' is up to date.
    Repository 'repo-oss' is up to date.
    Repository 'repo-update' is up to date.
    Repository 'telred-opensuse-42.2' is up to date.
    Retrieving repository 'vivaldi-beta' metadata -----------------------------------------------------------------------------------------------------------------------------------------[]
    Warning: File 'repomd.xml' from repository 'vivaldi-beta' is unsigned.
    
        Note: Signing data enables the recipient to verify that no modifications occurred after the data
        were signed. Accepting data with no, wrong or unknown signature can lead to a corrupted system
        and in extreme cases even to a system compromise.
    
        Note: File 'repomd.xml' is the repositories master index file. It ensures the integrity of the
        whole repo.
    
        Warning: We can't verify that no one meddled with this file, so it might not be trustworthy
        anymore! You should not continue unless you know it's safe.
    
    File 'repomd.xml' from repository 'vivaldi-beta' is unsigned, continue? [yes/no] (no):
    Retrieving repository 'vivaldi-beta' metadata     .....................................................................................................................................[error]
    Repository 'vivaldi-beta' is invalid.
    [vivaldi-beta|http://repo.vivaldi.com/snapshot/rpm/x86_64/] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'vivaldi-beta' because of the above error.
    Some of the repositories have not been refreshed because of an error.
    

    Do I report is as a bug?

    Cris



  • Cris, maybe this won't advance the matter at all for you, but FYI:

    0_1503655355355_upload-df163d4c-234e-4249-bb6e-5aefc843192b

    0_1503655383629_upload-418f1458-f639-4616-a8ed-0e3598dd6bbc

    0_1503655408376_upload-5c548177-f413-43ef-9fa0-f5c5b5a14bea



  • @Cris70 said in Vivaldi-beta repo: package signature?:

    Do I report is as a bug?

    No, it is already known.
    VB-12260 "[linux] The rpm/yum repositories are unsigned"



  • @Steffie thank you. I'd say it is the same as mine, except for the fact that I don't have the stable installed.

    0_1503656005759_Screenshot_20170825_120700.png

    0_1503656017708_Screenshot_20170825_120731.png

    0_1503656250471_Screenshot_20170825_121720.png

    Cris



  • @Gwen-Dragon said in Vivaldi-beta repo: package signature?:

    @Cris70 said in Vivaldi-beta repo: package signature?:

    Do I report is as a bug?

    No, it is already known.
    VB-12260 "[linux] The rpm/yum repositories are unsigned"

    Oh ok, thank you.
    Hope it gets fixed soon, then.
    Accepting unsigned repos and packages makes me nervous... :cold_sweat: :grinning:

    Cris



  • @Cris70 I can not test with rpm yet.
    What happens if you download https://downloads.vivaldi.com/snapshot/vivaldi-snapshot-1.12.941.3-1.x86_64.rpm, install the rpm and then update yum.
    Do you get the error about unsigned repo data?



  • @Gwen-Dragon I did what you asked. However, since I had already accepted the unsigned repo, I had to delete the repo otherwise I would not get the warning again.

    I thought that installing the downloaded vivaldi-snapshot package would automatically re-add the repo, but that turned out to be not true.

    So I had to re-add the repo manually. Did it through Yast and again had the same warning as before:

    0_1503658979336_Screenshot_20170825_130242.png

    Hope this helps...
    Cris


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.