Vivaldi takes several minutes to start up



  • After a reboot of my PC, Vivaldi takes at least three - 3 - minutes to start up after clicking the icon. And I don't know if it helps or not, but after that time I press Vivaldi multiple more times in a row, to "help it along". It then finally opens, with my last session, and a lot of blank windows (because of my hurried clicking). I have around 10 tabs open (with none of them loading until I click it) and 5 extensions installed.

    I can see that in Task Manager, Vivaldi.exe is already running at least two processes from the moment I click the icon, but it won't actually start up before way later.

    My specs:
    1.10.867.38 (Stable channel) (64-bit)
    OS Windows 7 64-bit i7-2670QM CPU @2.20 GHz 2.20 GHz
    8 GB RAM

    I thought Firefox was slow to start, and that only takes ~45 seconds.


  • Moderator

    @Nebu Mine takes 5 sec cold and 2 sec after it has started for the first time - and on statistically weaker hardware than yours for browsing (well, I do have 16 GB RAM, but nothing like an i7 processor.) Mine is basically a 4-core AMD 3.6 GHz (which tho higher "specs" is in practice slower than most i7's) - BUT my ancient P4 on my laptop does 'WAY better than your setup.

    First, quit the multiple clicking. Just quit it. You are slowing everything by doing that.

    Second, what sort of 3rd party security software do you run?

    Third, do you have fifty thousand bookmarks, over two hundred downloads in your completed download list, a huge history file, a session with 200 tabs in it?

    Do you have a whole mess of extensions - or even a single "security" extension that has to examine everything in detail before anything can open?

    Help us fill out the picture here.



  • @Ayespy said in Vivaldi takes several minutes to start up:

    @Nebu Mine takes 5 sec cold and 2 sec after it has started for the first time - and on statistically weaker hardware than yours for browsing (well, I do have 16 GB RAM, but nothing like an i7 processor.) Mine is basically a 4-core AMD 3.6 GHz (which tho higher "specs" is in practice slower than most i7's) - BUT my ancient P4 on my laptop does 'WAY better than your setup.

    First, quit the multiple clicking. Just quit it. You are slowing everything by doing that.

    Apologies. It's only when I do that (seemingly) that Vivaldi eventually decides to open, though. Or maybe I'm just doing the rain dance at that point.

    Second, what sort of 3rd party security software do you run?

    As in, my Windows system? Only Windows Defender.

    Third, do you have fifty thousand bookmarks, over two hundred downloads in your completed download list, a huge history file, a session with 200 tabs in it?

    I haven't saved any sessions, except for this current one, which has only around 10 tabs in it.
    I have ~100 bookmarks, probably ~50 finished downloads (cleared that now). How can I check the history file?

    Do you have a whole mess of extensions - or even a single "security" extension that has to examine everything in detail before anything can open?

    The extensions I have are: Font Changer with Google Web Fonts, Ghostery, Google Docs Offline, Hover Zoom, LastPass, Page Refresh, uBlock and Wikiwand.


  • Moderator

    @Nebu No OBVIOUS culprits. What happens if you refresh your profile?


  • Moderator

    @Nebu And, too - I'm a bit surprised that Google Docs Offline works in Vivaldi. It seems it might require a Chrome-only interface.



  • Could you please do the following:

    go to vivaldi://about --> copy or remember the path that is listed in the line "Profile Path" (it should end with your default folder) --> close vivaldi --> go to that path --> search for a file named "Preferences" --> open this file with a text editor --> press "Ctrl +F" or open the in text search via the menu --> search for vivaldi_window_1

    The line should look like this:
    "vivaldi_window_1":{"h":999,"screen_bounds_h":1040,"screen_bounds_w":1920,"screen_bounds_x":0,"screen_bounds_y":0,

    Now please look at the values that are set for X and Y --> screen_bounds_x":0,"screen_bounds_y":0, they should be set to 0 (zero). Those values mark the position where the upper left corner of your first vivaldi window is placed while x=0 and y=0 are the most upper left corner of your monitor.
    If they aren't set to zero write down the actual values (backup reasons) than please set them to zero and save the file than restart vivaldi but please make sure that you click the icon only once!

    In your case I am not completely sure if this will fix it but the point that you said you've to press the icon multiple times makes it worth a try. This happens sometimes that the first vivaldi window is placed outside of the vivsible area of your screen and with this you can bring it back.
    Keeping my fingers crossed that this will help ; )



  • @Nebu Another thing to try, just to be sure, would be disable all of the extensions (Tools > Extensions) and then restart Vivald after that. If it clears the problem, next try re-enabling the extensions one at a time with restarts in between, to track down the culprit.



  • @zaibon: There is no line with the words "vivaldi_window_1" or "screen_bounds" in that file.

    @Blackbird said in Vivaldi takes several minutes to start up:

    @Nebu Another thing to try, just to be sure, would be disable all of the extensions (Tools > Extensions) and then restart Vivald after that. If it clears the problem, next try re-enabling the extensions one at a time with restarts in between, to track down the culprit.

    I'll try this now.

    @Ayespy said in Vivaldi takes several minutes to start up:

    @Nebu No OBVIOUS culprits. What happens if you refresh your profile?

    I will try this when I can be bothered. (Stuff like this sucks the life out of me.)

    As for Google Docs, I don't remember even installing it, but I probably had to to do some commands. It works, anyway.

    Fun fact: When closing Vivaldi just now, to locate the preferences file, and re-opening it after, nothing happens. I tried twice more (a few minutes in between) to open Vivaldi. No luck. After ~5 minutes, I press a few times, and it suddenly opens (with 4 extra blank pages, I probably pressed 5 times). It's like it does not want to run sometimes.

    This used to just happen when starting Vivaldi for the first time after a boot. Now it occurs when closing and launching it regularly too. Not all the time, though, so it's a bit hard to track this one down.



  • @Nebu said in Vivaldi takes several minutes to start up:

    There is no line with the words

    Damn - that this happens is pretty rare. When you clicked the vivaldi Icon once can you select it with "Alt + Tab" (you maybe need to hold Alt and press Tab multiple times to select vivaldi) if yes than please press afterwards "Windowskey + Arrow Down" followed by "Windowskey +Arrow Up"



  • I've run into another problem now that complicates matters. The hard drive Vivaldi is installed on seems to be failing. That would explain why Vivaldi hasn't opened at all recently (the drive doesn't register it or something). I will get back on this once I've sorted this out... :(

    Thanks all for your help!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.