Vivaldi starts Discrete Graphics



  • Vivaldi works well for me. At this point my major issue is that it triggers the discrete graphics. Which is fine for performance but decreases my battery life and will eventually burn my leg ;) . Is it possible to disable it somehow? (P.S. Mine's Macbook Pro Retina 15" Late 2013 model with Nvidia GT 750M)



  • Check out gfxCardStatus, a menubar app, I believe it is free
    gfx.io
    It may help, even if only temporary



  • Thanks. That helps.

    Hope we get a more permanent option later on. :)



  • Just wanted to weigh in and second this. I can use GFX card status for now, but it's something that I'd like to be able to control from the app itself.

    If I can get comparable battery life with Vivaldi vs. Safari, it'll be my browser on all platforms. :)



  • Vivaldi still tries to select discrete graphics when it starts. This is the only forum post I can find that refers to the issue. Anyone know of a way to force Vivaldi to use the inbuilt graphics card?



  • try to disable all of GPU related options in vivaldi://flags



  • @Csineneo Upping the post.

    Just stumbled upon the fact, that Vivaldi doesn't support automatic graphic switching on my MacBook Pro (Early 2011), which is sad in 2017.

    Disabling all of GPU options is not the best way to go. No other modern browser switches GPU to discrete on launch (at least, I can say for Firefox and Safari), but does so only when needed, for example, on a page with video. Draining battery this fast isn't a good idea.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.