Keyboard does not work under Mint (with X Neural keyboard layout switcher)



  • Tried Vivaldi 1.11.917.39 64-bit and the latest Snaphot on two quite different computers under Linux Mint 18 Sarah Cinnamon and Linux Mint 18.2.
    In all cases it's impossible to enter any letter to any field in Vivaldi browser. There's no reaction to any keystroke. I'm very surprised.

    //modedit: change title



  • Strange.
    The keyboard does not work on webpage's textfield or textarea? Or only in Vivaldi's address field or search field?



  • @Gwen-Dragon
    On any text field in browser window. Both in Vivaldi address and search fields and on any webpage text fields.



  • Works on 18.2 Mint Cinnamon for me.
    Tested with a fresh install.

    If you start Vivaldi from shell, any error messages?



  • I don't know how to start it from shell, never tried.
    Upd: started from shell using Š° commandline in vivaldi://about
    No errors reported, keyboard inactive also.



  • @alex133 use the following command in your terminal:
    /usr/bin/vivaldi-stable



  • Tried this command too. The same effect - no errors and no keyboard.



  • @alex133
    This is one of the strangest bugs I read about so far.
    I don't have much knowledge about linux but my questions are what kind of keyboard do you use - anything special?
    And what is your native language? (Honestly I doubt that this has something to do with your error but just to make sure)

    EDIT: Or do you use some special programs that run in the background like speech to text or some similar stuff that might interfere with your keyboard?



  • Nothing special - ordinary keyboards, the cheapest ones. And two PCs with totally different hardware.
    My language is Russian, but I tried to change Vivaldi to English.
    In addition - any other browsers (Opera, Firefox, Chromium) or other programs work fine with keyboard while Vivaldi is started.



  • @alex133
    Was this a new install or upgrade.
    If it was an upgrade try starting with a new profile path.
    In terminal
    vivaldi --user-data-dir=$HOME/vivaldi-test-profile
    This will run vivaldi using a vivaldi-test-profile folder in your home directory as the config path.
    Can be deleted when finished testing.



  • It was a new install of Vivaldi on 2 different computers.
    Test profile does the same.



  • I can not reproduce your issue on my 18.2 Mint Cinnamon.



  • I'm on Mint 18.2 (Cinnamon - 32bit) and works fine for me.

    as @zaibon says in the Edit note could be something interfere with keyboard. Maybe you have some active settings or software that is focused in background or in another space (look at the dektop workspace).
    Another thing that you can try is maximize Vivaldi (to be sure of that, try to open the panel on right side by clicking over).
    Also, try to ALT + (drag and move window elsewhere), than maximize again and try to write.


  • Moderator

    Mint 18.1 Serena/Cinnamon 64-bit, all updates including kernel and firmware, fairly common Logitech wireless keyboard and mouse combo - all working as expected in all parts of the browser, text windows, address bar, etc.

    I do NOT use any other desktop or window managers than just what comes prepackaged with Mint.



  • Wow! I've found the spoiler finally.
    It is X Neural keyboard layout switcher. Thanks to @zaibon note.
    But I'm not ready to get rid of this extremely helpful program.
    I must make them work together somehow.



  • @alex133
    O_o woah - that was just a shot into the blue and to rule out some very unlikely stuff.



  • @alex133 said in Keyboard does not work in Vivaldi under Linux Mint:

    Wow! I've found the spoiler finally.
    It is X Neural keyboard layout switcher.

    Oh. Yes, with other keyboard layout programs you can have funny things as unexpected non working shortcuts.

    Can you report the issue to Linux Mint bugtracker and Vivaldi bugtracker?
    May be they can investigate and find a solution?


    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    If you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!




  • @alex133 said in Keyboard does not work in Vivaldi under Linux Mint:

    X Neural keyboard layout switcher

    On my GNOME the xneur duplicates all keys in Vivaldi, really strange.



  • @alex133 good that you find the reason ;) this can be helpful for other users, in the future :thumbsup:



  • Confirmed your bug VB-32002 "[Linux] Keyboard does not work X Neural Switcher"


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.