Stop Vivaldi from opening at startup on macOS



  • Can't figure out how to get Vivaldi to stop opening at startup on macOS Sierra, even though it's not the default browser anymore. I want to control when it opens, but can't find a setting that will work to do that. Please educate me and any others who have this problem.



  • System Preferences -- Users & Groups -- Login Items: select Vivaldi from the list and click the minus sign.

    I don't know why your system is setup to start with Vivaldi, but it has to be set as startup item for it to load at system start. How this happened if you didn't set it yourself, hard to tell. But to my knowledge Vivaldi has no code in place to startup automatically.

    And yeah, close Vivaldi with command-Q or over the Menu item Quit, before shutting down your computer. It could be your system is just restarting applications that had been running while you shut down macos.


  • Moderator

    If you right-click on a Dock icon, one of the Options that you can enable (or disable) is "Open at Login". It's pretty easy to do this accidentally while trying to do a "Keep in" (or Remove from) Dock, and doing this would add the application to the Login Items in the Users & Groups preferences as well.



  • @xyzzy
    Thanks, though that wasn't my problem. But the Users & Groups setting was.



  • @luetage
    Thanks. The Users & Groups setting fixed it!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.