Webm / mp4 lagging when sound is active



  • Hi guys,

    new at this forum and I just want to ask, if it is only me or if this is a general experience with the latest Vivaldi (1.11.917.39 (Stable channel) (64-Bit)) release:

    I like to browse some image board from time to time. One is a German one - http://pr0gramm.com/top <- sfw when you don't have an account where it is turned off on purpose. There're some webms and mp4s file uploaded as well and some of them have sound.

    Now the issue is, that they load just fine, until you enable the sound of those file, then they lag / stutter, even when played on repeat (loaded from cache).

    Anybody else having this issue as well? I reported it already to the bug report system, since I'm sure it is not a problem with my PC (all resources are plenty available and it just fine with Firefox and did work fine with the previous release).

    Kind regards
    Veron



  • They seem to play fine for me with audio enabled.
    Try if it changes anything for you:
    settings/appereance/use animation (untick)
    the tab animation of the loudspeaker is known to slow down the playback of youtube 60fps videos, maybe you are experiencing a similar problem.
    Another suggestion is to try to disable/enable video hardware acceleration if it changes anything for you.
    vivaldi://flags/#disable-accelerated-video-decode



  • @iAN-CooG said in Webm / mp4 lagging when sound is active:

    They seem to play fine for me with audio enabled.
    Try if it changes anything for you:
    settings/appereance/use animation (untick)
    the tab animation of the loudspeaker is known to slow down the playback of youtube 60fps videos, maybe you are experiencing a similar problem.
    Another suggestion is to try to disable/enable video hardware acceleration if it changes anything for you.
    vivaldi://flags/#disable-accelerated-video-decode
    This helped me! Thanks a lot! I don't know why, but it was working fine with those settings before the update!


  • Moderator

    @veron91 Does that mean disabling animation helped you?



  • @Gwen-Dragon said in Webm / mp4 lagging when sound is active:

    @veron91 Does that mean disabling animation helped you?

    Yes. The problem is gone, but as I said before: Those settings were the same as before the update, so I don't know why it is causing problems now.



  • Maybe it's something different on your pc, for me animation enabled or disabled on that site doesn't make any difference. Hard to nail bug if it is one.



  • @iAN-CooG said in Webm / mp4 lagging when sound is active:

    Maybe it's something different on your pc, for me animation enabled or disabled on that site doesn't make any difference. Hard to nail bug if it is one.

    Thanks for testing - I will test it with another PC and let you know.
    Kind regards


  • Moderator

    I set your bug report to resolved as you had a workaround.



  • @Gwen-Dragon said in Webm / mp4 lagging when sound is active:

    I set your bug report to resolved as you had a workaround.

    Yes, ok. I also did test it on my machine at home (much more powerful) and there is no problem with animations on. Seems that it is an performance issue, that either got worse with the update or my other PC has some problem, that I couldn't figure out yet.

    In any way: I can live with the workaround! Thanks @all for helping and responding to this! <3


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.