Blocking cupsd in firewall stops Vivaldi from viewing webpages



  • I have my firewall set to interactive mode so that it alerts me to any traffic pattern that doesn't have an explicit rule. Mostly because of MS Office. Anyway I noticed /usr/sbin/cupsd was requesting internet access at odd times so as a test I blocked it entirely. Lo and Behold I can no longer use Vivaldi. I get "page unavailable" messages for every single page. Removing the rule resolves the issue entirely. Logs show that cupsd is trying to access whichever IP address I was browsing to in Vivaldi.

    I can find no printer settings (or flags) in Vivaldi that could account for this behavior. Google searches turn up nothing. MacOS Sierra 10.12.6 and Vivaldi 1.11.917.39 (Stable channel) (64-bit).

    So my question is: why in the world does it seem that Vivaldi is going through cupsd to access the internet and how do I go about troubleshooting why this might be occurring?



  • Ok so I found the issue. My firewall was falsely reporting which app was requesting the access to the internet. cupsd has nothing to do with Vivaldi as far as I can see.

    Be careful of the ESET firewall people. Frequent restarts are apparently necessary to avoid this erratic behavior when using Interactive mode.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.