Some Browser icons, buttons, and text have gone white-on-white 1.11.917.39



  • Ubuntu 16.04 and no peculiar extensions. My menu and status controls and the Settings panels have gone white-on-white. Buttons, and icons show on mouseover in the menu and status area. I was hoping I could fix it by changing some of my settings (I have many non-default settings) but the settings panels are completely white-on white except for visible checkboxes and radio buttons.

    I do love the many cosmetic changes in 917.39- they are great- especially for some of the customized looks that I have selected. However, the white-on-white is not so good.


  • Moderator

    Which CPU and GPU do you have on your hardware?
    Perhaps a problem with your graphic card driver.

    Try first to override GPU blacklist.
    vivaldi://flags/#ignore-gpu-blacklist
    Try second to disable Hardware Acceleration with internal setting.
    chrome://settings/?search=hardware



  • Thanks for the quick response.

    It is an old box. Intel I5 with a Radeon HD 6450 - 8450 series and Gallium. The suggested Vivaldi and Chrome config changes make no difference. I have not had any display problems with quite a wide a wide assortment of software that I use.

    I do have many non-default settings and love the many features of Vivaldi as a result. I Currently run and use (for testing) five different browsers available on Linux , all the latest versions. Some have features that I need occasionally (e.g. Opera) but overall Vivaldi is in a class by itself.

    I will probably boot up another box and see if I can bring up an older Vivaldi and try to transpose-guess my way through going back to Setting defaults. A few of the title popups appear in the Settings window, and the far left panel has an off-white background and it is almost possible to make out the choices which are in pure white. I'll see what I can do later today.


  • Moderator

    We have sometimes problems if notebooks have two GPU (a internal Intel and other like AMD oder NVidia) to display the user interface or video correctly, but that depends on driver and Linux distribution.

    I got a white-on-white page only once on a Debian with a Intel GPU driver, but that was in 1.10 and could have been a result of a crashed video process.



  • @Gwen-Dragon
    I was just updating my status. Yes, I have multiple Display drivers on the box.

    At any rate I stumbled through the mostly invisible Settings panels and by selecting one of the default themes, all is fine. No idea what it was that caused my wonderfully anal theme to fail, but since there are about half a zillion theme options, I suppose that will be a quirk never resolved completely.

    I do love Vivaldi and have recommended it to every "power" user. I wish everything that I write measured up. You folks should be very proud indeed.


  • Moderator

    @internet Oh, it was a strange Theme setting by you that caused it?
    Hmm, yes can happen editing a theme and using some starneg values.
    But be happy as it is working now with an other theme :)



  • @Gwen-Dragon said in Some Browser icons, buttons, and text have gone white-on-white 1.11.917.39:
    Believe me, I understand the problem, but I am not sure why using the standard configuration choices would be called "strange" choices especially when they worked just fine through many updates of Vivaldi. But I really do understand the likelihood of that happening when there are countless possible places for problems to develop when you folks upgrade. No way can they all be checked. Incidentally, the overall changes that you made regarding the background and contrasting items in 917.39 look like they handle most of the visibility changes that my "strange" choices were trying to do. You folks really are great. And an amazing response time to boot!


  • Moderator

    @internet Sorry, i do not know what went wrong. I am only a helper not a internal dev. :peace:
    I thought you may have edited a theme and such change may have been causing the whitish page. I misunderstood you, i am not a native english speaking person.
    I am using contrast setting (having :eyeglasses: and bad :eyes: ) in Settings → Appearance
    so i may not get such low contrast in a theme.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.