Very Clunky Scrolling since Vivaldi 1.11



  • I just downloaded Vivaldi 1.11 and I have noticed that the scrolling on all pages is much more clunky, slow and laggy. Does anyone know the cause of this or a possible fix?

    macOS Sierra 10.12.6
    Vivaldi 1.11.917.39 (Stable channel) (64-bit)

    //modedit changed title


  • Moderator

    Can you try to deactivate smooth scrolling in Vivaldi's Settings → Webpages?



  • Me, too. Content has been displayed quickly so far.
    I can confirm that it is gradually displayed from the top to the bottom now.
    Scroll is also not very smooth. Access speed is not slow.

    Can you try to deactivate smooth scrolling in Vivaldi's Settings → Webpages?
    It doesn't improve.

    macOS Sierra 10.12.6


  • Moderator

    @BlazeKing252 It's possible that the graphics chip in your Mac was blacklisted in the Chromium 60 code that Vivaldi 1.11 is built upon. If that's the case, scrolling will not be as smooth as it once was because the browser is now rendering everything in software.

    Unfortunately, the GPU-related code changes in the Chromium base are completely beyond Vivaldi's control... and they affect Google Chrome users as well.



  • I enabled #ignore-gpu-blacklist, and approached the state like before. But the smoothness of scrolling has not changed much.
    My GPU is nvidia GTX680.

    Graphics Feature Status
    Canvas: Hardware accelerated
    CheckerImaging: Disabled
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Hardware accelerated
    Rasterization: Hardware accelerated
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated

    Below is the case where ignore-gpu-blacklist is invalid

    Graphics Feature Status
    Canvas: Hardware accelerated
    CheckerImaging: Disabled
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Hardware accelerated
    Rasterization: Software only, hardware acceleration unavailable
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated

    I made it effective. It seems that there is no effect on problems that can't play videos with Vivaldi.


  • Moderator

    @izacks GPU Hardware acceleration is working on your system. If it had been disabled, either intentionally or if your GPU had been blacklisted, the output of vivaldi://gpu would have looked something like this:

    Graphics Feature Status
    Canvas: Software only, hardware acceleration unavailable
    CheckerImaging: Disabled
    Flash: Software only, hardware acceleration unavailable
    Flash Stage3D: Software only, hardware acceleration unavailable
    Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
    Compositing: Software only, hardware acceleration unavailable
    Multiple Raster Threads: Disabled
    Native GpuMemoryBuffers: Software only, hardware acceleration unavailable
    Rasterization: Software only, hardware acceleration unavailable
    Video Decode: Software only, hardware acceleration unavailable
    Video Encode: Software only, hardware acceleration unavailable
    WebGL: Unavailable
    WebGL2: Unavailable

    Since your GPU was not backlisted, overriding the blacklist in vivaldi://flags would have had no effect.

    Sorry for going off topic but regarding your video playback issue, do you have a link to a video (ideally something public on a popular site, like a YouTube video) that Vivaldi cannot play on your system? Vivaldi knows that video playback doesn't always work on systems with blacklisted GPUs but your situation is much less common. It might be helpful to them if you filed a bug at https://vivaldi.com/bugreport/ to let them know that video playback doesn't always work on your hardware.

    Thanks!



  • @xyzzy I dont think thats the case because the latest version of Chromium is scrolling just fine.


  • Moderator

    @BlazeKing252 I think you're right; scrolling does seem to be slightly more laggy... even with extensions disabled.



  • @xyzzy said in Very Clunky Scrolling on Vivaldi 1.11 for Mac:

    @BlazeKing252 I think you're right; scrolling does seem to be slightly more laggy... even with extensions disabled.

    I can concur. After the upgrade to 1.11, I noticed that scrolling had changed in macOS (Windows is the same as before). It felt far more like the Smooth Scrolling feature that I dislike and keep disabled. I thought that the feature may have been force-enabled during the update, but Vivaldi shows it as disabled in the settings app. While I've gotten used to it somewhat since yesterday, it still feels less precise (maybe that is the latency/lagginess). Something just feels off, but it is hard to put into words. All I know is that it is different.



  • Is this problem changing with the Snapshot version 1.12? Other people said, "Because Chromium's own specification change, Vivaldi can't solve it." If I hate this behavior, do I have to give up Chromium based browsers in the future?



  • This issue is already known as VB-30992. ;)


  • Moderator

    @izacks The Vivaldi 1.12 snapshot feels the same as 1.11 stable release. For me, it's not horribly bad, even on an older MacBook Pro with a blacklisted GPU. That said, there is still a very noticeable difference between Safari, Chrome/Chromium, and Vivaldi.

    On imdb.com, try scrolling from the top to the bottom of the page... slowly, a bit faster, and with inertial scrolling... first with Safari, then Chromium, then Vivaldi. Safari is perfectly smooth, Chromium is fine, but Vivaldi feels rough by comparison... and Vivaldi's inertial scrolling just doesn't feel right either.

    Another thing that I'm a bit concerned about is the very existence of the "Smooth Scrolling" option in Vivaldi's settings; I'm not sure what it does on macOS. If you look for "Smooth Scrolling" in vivaldi://flags, it says "Sorry, this experiment is not available on your platform." It hopefully does nothing... or just toggling the option on a Mac might put the configuration into a bad state... I simply don't know.



  • I can confirm that on my iMac 27 Vivaldi scrolls terrible. Chrome is really smooth. I tried both 1.11 and 1.12 and its the same.

    For me Vivaldi is unusable, choppy/laggy scrolling makes eyes hurt. It's such a shame.

    Playing videos on youtube is fine, even when it's 4k.

    Btw.
    On bootcamp with windows 10 everything is perfect.


  • Moderator

    Thanks for the update. If scrolling is particularly bad for any of you, could you please post a reply to this topic/thread? When you do, kindly include the following:

    1. The exact model of Mac that you're using. (To determine this, click on the Apple logo in the Menu Bar, select "About This Mac")

    2. Indicate whether or not you have overridden the GPU blocklist in vivaldi://flags

    3. A link to a website where scrolling performs poorly

    I'll be sure to let the folks at Vivaldi know about this topic.

    One other thing: as the owner of a Mac with a blacklisted GPU, I tend to get the worst scrolling experience on some sites when I override the blacklist. My theory is that my GPU got blacklisted in the first place because some of their code changes caused performance issues such as this.

    That said, with or without hardware acceleration, scrolling on Vivaldi is not as smooth as it is on Chrome (default install, hardware acceleration unavailable).



  • If the scroll is really bad, also an extension to override scroll could be tried.



  • Hi, I don't know if this can help, but it seems that I have the exact same problem on Windows. This appeared in with the early 1.11 snapshots and I still can't understand where the problem come from. So for now I'm still using the 1.10.

    I opened a thread for this some month ago, witout any success...
    https://forum.vivaldi.net/topic/20012/lag-when-scrolling-with-latests-snapshots



  • Scrolling is really bad compared to Firefox (windows and linux)
    :frowning2:



  • I upgraded from 1.10.867.48 to 1.12.955.36.
    Regarding the dullness of scrolling, I think there is not much change. This may be a placebo, but it feels a bit faster. I feel 1.12 is smoother than 1.11, but I feel it is generally heavy.

    I'm considering going back to 1.10 again.



  • After that, I returned to 1.10.867.48. After all this is the natural behavior.
    At 1.12, changing GPU to software rendering didn't change.

    Black list of GPU. Chromium's specifications?
    Will the behavior of 1.11 be the basis in the future?


  • Moderator

    @izacks Chromium leaves us little choice going forward. It keeps changing, and breaking items in Vivaldi. We just have to keep trying to adjust.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.