[Solved] YouTube video still in background: hours later after closing tab



  • Hey guys,

    this is a very weird bug that I've just stumbled upon right now. This morning I was watching some Colbert's skits on YT, when right in the middle of debugging nearly 3 hours later on the same machine I noticed in Xfce's Task Manager that I still have a video 'running' in Vivaldi, with nearly 300 MBs of RAM consumed and average 0.5% CPU utilisation.

    I immediatelly went to Vivaldi only to find out that of course that video is in none of (very few) open tabs, and even Vivaldi's own TM didn't show anything that Xfce's TM showed very clearly as running tab.

    So I just restarted Vivaldi like I always do and problem 'solved'. The reason why I let you know this is that I noticed some sort of 'slowiness', 'sluggishness' especially after 'YT raves', or when I tend to open&close many videos at very little time frame. I have an idea that this behaviour may be caused by some tabs left 'hanging' in the background, just like I found out (incidentally) today.

    The real question is this: how do I report this issue to you in a way that you would ever be able to figure this out? Like I said, I think this is a regular thing with current Vivaldi stable when you actively watch many YT videos, but of course this is kind of a nightmare to reproduce. Any ideas?

    Thanks in advance and have a great summer in the North! ;-)

    P.S.: System Info...

    https://paste.sh/OTL8g-Ze#s-AVTRhn_ic80Zrj4yxbiZV0



  • Hi, check background activities:

    vivaldi://chrome/settings/search#hardware

    or better uncheck it. :)

    Cheers, mib
    EDIT: or use F2 and search for hardware


  • Moderator

    Open vivaldi://chrome/settings/search#background apps
    Deactivate Continue running apps in background should help.



  • I'm starting to think that "background app" setting being on by default is there just to cause problems. It's one of the 1st things I've disabled after starting using Vivaldi



  • @Gwen-Dragon @mib2berlin Thank you guys, this seems to have solved the issue. I've been testing for the past two days and Vivaldi no more requires restarting after every couple of hours.

    Great to know the cause of this issue & @Vivaldi-Team please consider making this setting as default. Thank you.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.