Protocol handler problem, not present in Local State.



  • I was using http://nexusmods.com which, when clicking on download buttons, lets you download the file using their application(nexus mod manager). I clicked on "don't open" accidentally(with the "always do this" option checked) and now i can't open any link in the application anymore. I tried going to vivaldi://chrome/settings/handlers but there's nothing there, and same goes for %userdata%/AppData/Local/Vivaldi/User Data/Local State (there's no "protocol handler" option, in the json). I even tried adding "protocol_handler:{ "excluded_schemes: { "nxm":false } } to it, still doesn't work. How do I revert this?


  • Moderator

    Perhaps in %userdata%/AppData/Local/Vivaldi/User Data/Preferences



  • Spot on. It was actually in %userdata%\AppData\Local\Vivaldi\User Data\Local State\Default\Preferences. And there i just changed the protocol_handler > excluded_schemes > nxm from true to false and now it works. Still kind of a bother though, it would be nice having the option to change this directly from the browser instead of having to search through tens of configuration files D:


  • Moderator

    @NSilv said in Protocol handler problem, not present in Local State.:

    it would be nice having the option to change this directly from the browser instead of having to search through tens of configuration files

    I agree, that is planned and will come, but the priority is not so high.

    If you think a feature is useful and missing in Vivaldi, please make a request.


    How to make a feature request for Vivaldi
    If you think your problem can be solved by a missing feature, please add a request at https://forum.vivaldi.net/category/48/features-requests in the corresponding thread for your browser version.
    Add one line in bold as a short title for the feature and 2-3 lines to describe the wanted feature.



Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.