Setting default homepage



  • Hi, I'm currently having trouble setting my desired default homepage. Whenever I type in the site and exit the settings window, my homepage settings were not saved. But if I get lucky it does but very rarely. This also happens just after I type in the site then switch between the settings tabs, it goes back to to last default. I already submitted a bug report for this since TP1 but I just want to know if anyone else is having trouble with setting up their default homepage and if you guys have any work around. This happens on both my Mac and PC.



  • I noticed that the homepage will only change if you add "http" or "https". It won't work if you only place "www." in front or just the domain "<website>.com"

    At least for me, this is clearly a bug.

    A shout-out to the devs! :)</website>



  • I had some trouble with this in the first technical preview, but managed to get it to take by restarting Vivaldi. It may be fixed in tech preview 2.



  • @terzaerian:

    I had some trouble with this in the first technical preview, but managed to get it to take by restarting Vivaldi. It may be fixed in tech preview 2.

    I'm actually using TP2. This was a problem for me since TP1.
    Did you try setting your homepage without http or https?


  • Moderator

    @Xypher:

    @terzaerian:

    I had some trouble with this in the first technical preview, but managed to get it to take by restarting Vivaldi. It may be fixed in tech preview 2.

    I'm actually using TP2. This was a problem for me since TP1.
    Did you try setting your homepage without http or https?

    It will, in fact, set with any leading transfer protocol statement - be it file:/// or vivaldi:// or http://. It will not set without the leading protocol statement, however.



  • @Ayespy:

    @Xypher:

    @terzaerian:

    I had some trouble with this in the first technical preview, but managed to get it to take by restarting Vivaldi. It may be fixed in tech preview 2.

    I'm actually using TP2. This was a problem for me since TP1.
    Did you try setting your homepage without http or https?

    It will, in fact, set with any leading transfer protocol statement - be it file:/// or vivaldi:// or http://. It will not set without the leading protocol statement, however.

    Yeah but that's the thing. The browser should, at least in my opinion, accept URLs with or without the protocol do be used. So it should accept at least the domain and domain name and at most a full URL.


  • Moderator

    @Xypher:

    @Ayespy:

    @Xypher:

    @terzaerian:

    I had some trouble with this in the first technical preview, but managed to get it to take by restarting Vivaldi. It may be fixed in tech preview 2.

    I'm actually using TP2. This was a problem for me since TP1.
    Did you try setting your homepage without http or https?

    It will, in fact, set with any leading transfer protocol statement - be it file:/// or vivaldi:// or http://. It will not set without the leading protocol statement, however.

    Yeah but that's the thing. The browser should, at least in my opinion, accept URLs with or without the protocol do be used. So it should accept at least the domain and domain name and at most a full URL.

    I agree this needs improved - but as long as you know the rules for the current implementation, you can use it with a little extra effort.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.