New User....Browser slow/Laggy (may be Avast or other antivirus app)



  • Hiya folks
    I have just started using Vivaldi for the first time today and I have a problem with its speed.
    It seems very slow to open up new links/tabs.
    For example when clicking on a link from my speed dial nothing happens for around 8 seconds, then suddenly there is a burst of activity and the page loads in less than a second.
    Another example, when registering for this site I filled out the details and when I hit the register button it did the same thing.... 8 second odd delay then a burst of activity and loaded in less than a second.
    It almost feels like there is a delay switch added before it does anything.

    I've tested and the delay seems to be the same no matter what I am doing. Clicking a link, opening from speed dial or Bookmarks bar.

    My system specs to give you an Idea of the hardware involved.....
    Intel 6600k at stock speeds
    32Gb Ram
    Nvidia G70 970
    500 GB Samsung 850 Evo as main drive (this is where Vivaldi is installed)
    2 TB Hitachi secondary drive

    This is a clean install of windows done yesterday just for your info.

    Any help you could give me, please?

    Even with the delays I am loving the browser so keep up the good work! :)



  • Hi Smeggy, check these posts below please, a few users are reporting exactly the same issue, me included!

    https://forum.vivaldi.net/topic/17413/slow-startup-of-vivaldi/23

    Rgs!



  • My system is with i5-7500 3GHz, 16GB RAM, GT710, 256 SSD and some 1TB HGST drives.
    It takes .5 to 1.5 sec to start Vivaldi, page display less than 1 sec.

    Where did you install the Vivaldi? On the SSD?
    You have Newest chipset and drivers for SSD and HD from manufacturers website?
    I remembering Windows 10 having some problems exchanging data between SSD and HD.

    And if you have onboard Intel GPU, disable it. Use NVidia as primary grpahics. Install the latest NVidia driver from NVidia.

    drivers from Windows install process (and Windwos Update) are sometimes buggy or out of date.

    Perhaps your antivirus make some trouble.



  • Hi thanks for the replies :)

    Vivaldi is installed on the SSD and I have installed all the latest drivers on my system. I checked the SSD and HD and all the relevant software was the latest.
    I tried disabling my antivirus (Avast) that made no difference.
    I didn't have any thing in my download list to delete, so it isn't that.



  • I remember some issues Avast slowing down, but i can not remember when it was some weeks ago.

    Try to reset browser profile to a fresh one and test, may be some data is broken.


  • Moderator

    @Gwen-Dragon Avast was clogging up Vivaldi just last week.


  • Moderator

    @Smeggy Do not be fooled. "Disabling" AV does not in any way remove its interference with your system and with programs it doesn't "trust." I've lost count of the number of users who have "disabled" AV and had no improvement, but suddenly it's perfect once AV is uninstalled or changed to another product.



  • Ok problem is fixed...all was suddenly working perfectly when I uninstalled Avast, so I guess that was the problem.

    Thanks for all the help folks it is much appreciated. :)



  • @Ayespy Thank you very much for your advices: since I was already planning changing from AVG to AVIRA, because of the ads and popups AVG fires every five minutes, I did tested VIVALDI while no AV was installed, and BINGO, the good and fast VIVALDI was back! Then, the final test, instaled AVIRA and tried VIVALDI again, and the good performance remained!
    Once again, thank you very much!!!
    Regards,
    Arthur



  • I added avast to the title, so users can quickly see that may be the cause of a slowdown.



  • I'd like to mention that when NOD32 scans my system, Vivaldi gets extremely slow. I have to revert to Firefox when that happens. I will have to try to see how Chrome acts in the same situation.



  • @Axonn
    My guess is that chrome won't be affected as it is big enough and well known so it probably is in the exception list of more or less any security program. No security company wants to have decreasing user numbers because they screw with the performance of the biggest browser.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.