current version horribly slow and laggy



  • This seems to have started in the past week so perhaps related to some Windows update ?
    Anyway, as soon as I attempt to do anything in the browser, it reacts very slowly (several seconds to open up a new tab, or even switch to another tab or bring up the menu).
    Looking at task manager, the vivaldi process starts chewing up 35% cpu on my quad-core i7.

    I did a WPR recording but since you guys don't seem to have public symbols, all it tells me is that the time is spent in vivaldi.child.dll

    I only have 4 tabs open and one extension (ublock origin, disabling which made no difference)

    Edit: By current version, I mean whatever release version is out there, 32-bit. It's to annoying to wait 10 seconds for help->about to load so I'm not going to bother with the exact version.


  • Moderator

    Slow graphics card?



  • Considering the problem appeared very recently, I would say that's unlikely.

    Chrome with 15 windows and 7-8 tabs each runs just fine as well.


  • Moderator

    @notyourbidness said in current version horribly slow and laggy:

    Chrome with 15 windows and 7-8 tabs each runs just fine as well.

    and has a different user interface.

    Internal (onboard) GPUs like Intel are slow.
    Vivaldi make much use of graphics as its user interface has more flexibility than Chrome, and is generated by HTML, CSS and JS.

    May be Vivaldi takes too much CPU.

    You have the latest Intel chipset and other drivers from Intel website? Windows does not always fetch the best drivers.

    Perhaps you like to report a bug to Vivaldi?
    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    if you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a link to a testpage where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!




  • I don't think it is related to slow GPU. I have much weaker AMD FX-4100 Quad and Radeon x1950pro from 2009 and I believe that nowdays all integrated GPU's are more powerful than my card. And it works pretty fast. This is more like windows/drivers issue. Do you have 7/10? Automatic windows updates?

    10 seconds waiting for showing About page, something must be very bad :/. Either with your vivaldi installation or windows installation.



  • Hi, you can try to disable GPU acceleration to test.
    Copy/past vivaldi://chrome/settings/search#hardware
    Sometimes the Windows driver for Intel iGPU are crippled or even broken.
    Same happen often for Nvidia too.
    Check Intel driver for you iGPU HD 4000/5000 or something.
    I use a GN 965 ultra low end iGPU without problems but on Linux.

    Cheers, mib
    EDIT: Help about open in 0.5 seconds on this system.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.