Vivaldi makes my GPU run stock



  • I have overclocked my GPU (HD 7870) to gpu 1100 mhz, mem 1300 mhz, and i noticed that when vivaldi is running, it makes my gpu run on stock values, wich are gpu 1000mhz, mem 1200 mhz. Does anyone have any idea what causes it, and how to fix it, or is it something that i just need to tolerate?



  • Sounds strange.

    What program do you use for OC'ing?

    Maybe try another program?



  • @MetaBaron:

    Sounds strange.

    What program do you use for OC'ing?

    Maybe try another program?

    I currently use MSI afterburner, but i tried sapphire trixx, and no effect.



  • Based on RRR13s recollection regarding Chrome, I did some research and stumbled upon this thread:

    http://www.tomshardware.co.uk/answers/id-2357476/asus-hd7970-dcuii-top-clock-speed-changing-overclock.html

    Anyway, it seems like the solution for your problem is to disable hardware acceleration for Vivaldi, see this thread for instructions:

    https://vivaldi.net/forum/vivaldi-browser/1342-hardware-acceleration

    Hope this helps :-)


  • Vivaldi Team

    @RRR13:

    Dunno if this will help you, but I remember reading some articles some time ago about Chrome boosting your CPU and/or GPU to perform better. People got pissed off because it killed laptop batteries fast and Google then gave up on this and turned it off and I think they gave an option to turn it on if you want to (not sure about the last part, though).

    That was simply to increase the clock precision from 15.6ms to 1ms when there is a lot of activity going on (blame badly written benchmarks such as peacekeeper for this). Unfortunately, this was also done when running on battery which was the real problem that got fixed. All browsers will do similar things when not running on battery. Not GPU related, though.



  • I tested a bit, and found out, that the problem is flash. I had to force flash on youtube, because the only option of resolution in HTML5 player in vivaldi is 360p. But where can i disable HW acceleration in flash?



  • Did you try

    vivaldi://flags/#disable-accelerated-2d-canvas

    ?



  • @MetaBaron:

    Did you try

    vivaldi://flags/#disable-accelerated-2d-canvas

    ?

    Yes i did, no effect.



  • The nuclear option remains:

    (Copied from Vivaldi thread referenced earlier):

    Try launching Vivaldi with the switch –disable-gpu

    1. Right click on your "Vivaldi" icon.
    2. Choose properties
    3. At the end of your target line add the command line flag. In this case:
    --disable-gpu
    4. With that example flag, it should look like: vivaldi.exe --disable-gpu



  • No effect with –disable-gpu :( , i guess i just have to live with the problem.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.