All fonts in development build (1.11.901.3) are rendered badly (compared to stable 1.10.867.48) with anti-aliasing disabled



  • Using the Vivaldi 1.11.901.3 dev snapshot I have severe rendering problems, too. I have antialiasing completely turned off in my system.

    While in the stable branch (1.10.867.48) the fonts are crystal clear (as expected), the fonts in the dev branch are very badly rendered (this affects the UI, as well as all websites, including the internal ones like vivaldi://about)!

    Here is a side-by-side comparison of Vivaldi stable (left) and dev (right):
    0_1500116099106_rendering.png

    The system font settings (Debian Jessie) haven't been changed in a long time, but the xserver was updated. However the stable Vivaldi version doesn't suffer this problem.

    So my question is, does anybody know what has changed in Vivaldi regarding font rendering (e.g. which settings are now relevant, which weren't before)?

    Any help greatly appreciated :)


  • Moderator

    I can confirm this if only the System font anti-aliasing is active.

    Please open your Linux systemsettings, go to Appearance of Applications, In section Fonts activate full font anti-aliasing with subpixels (sorry with my german KDE 4.14 i do not remember yet the correct english names of the sections and settings).



  • @Gwen-Dragon: Thanks for your suggestion, the anti-aliasing setting indeed has an effect on the fonts in the dev build.

    However, the fonts look blurry then, like I perceive anti-aliasing in general. Most people seem to like it, but some (probably the minority) don't -- see e.g. this marvelous blog post.

    That's why I turn antialias off everywhere by intention... and the browser is very crucial because you read a lot with that program.

    So, I hope there are other solutions to get the behavior of the stable branch back.


  • Moderator

    @m.p.y. I knwo teh different font renderers, Windows got worse over the years.
    But Linux does not use the Microsoft ClearType rendering, on Linux the fonts are sharper. And it depend how you set subpixel rending.
    See Step 3 in article.

    Do you have a blur because of graphics card?
    vivaldi --disable-gpu
    Is the font sharpness better then?

    Perhaps reconfigure helps:
    sudo dpkg-reconfigure fontconfig-config



  • @Gwen-Dragon: Unfortunately vivaldi --disable-gpu makes no visible difference; the subpixel setting should IMHO make no difference with antialiasing disabled.

    The fonts in the dev build look like fonts which are optimized for antialiasing are employed, albeit antialiasing is disabled. I will investigate further if some strace logs of Vivaldi stable compared to Vivaldi snapshot will shed some more light onto the issue.


  • Moderator

    @m.p.y. said in All fonts in development build (1.11.901.3) are rendered badly (compared to stable 1.10.867.48) with anti-aliasing disabled:

    The fonts in the dev build look like fonts which are optimized for antialiasing

    No fonts in Linux are optimzed for Antialaising as i know. Perhaps you need some X11 bitmap fonts for your better display with no anti-aliasing.

    Or perhaps you have a broken font or font which was badly designed. I had this with some Droid Sans font family.

    You can inspect the Vivaldi UI by context menu Inspect to check the used font in UI.
    Startiwith shell vivaldi --debug-packed-apps --silent-debugger-extension-api
    Hover a Vivaldi UI element
    Select Inspect
    In Developer Tools in a pane the tab Styles exists
    In this tab at the right side are many entries of used CSS settings.
    If you enter font in the filter field you can see used fonts
    Scroll down to Rendered Fonts.
    That is the font Vivaldi uses from your Linux.


  • Vivaldi Translator

    @m.p.y.
    I suggest to also test it in Chromium/GChrome Beta & Canary, cause it's Vivaldi Snapshot. Chromium upstream does "creative" with fonts view although most of time not happen for Linux version.

    As you might notice, I'm in sid. Either Antialias on or off fonts relatively "dark" here. Not "real black" as I want to, but it's not like in your screenshots.



  • @m.p.y. Sorry for replying late, but I want offer a possible solution after some digging in the source code of vivaldi, fontconfig and freetype.
    I believe this is an issue with vivaldi(/chromium) bundling some newer rendering enginges than what's installed on your debian (or my slackware) system. If you set the FREETYPE_PROPERTIES environment variable to truetype:interpreter-version=35 you can instruct the newer freetype version to use the old font-hint-interpreter.

    FREETYPE_PROPERTIES=truetype:interpreter-version=35 vivaldi



  • @lars-l I'm also sorry for my late reply, but somehow I haven't received a notification or I have overlooked it.

    And thank you very much for your valuable answer! :thumbsup:

    In the meantime the problem doesn't occur in the current snapshot (1.12.953.8) anymore -- even with default FREETYPE_PROPERTIES.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.