Can not open links to microsoft.com


  • Vivaldi Translator

    When I try to open the link: https://www.microsoft.com/en-us/garage/profiles/presentation-translator/

    The latest 1.11.901.3 will show the below error message. I tried with latest Firefox 55b8 (with the same addons - uBlock and Privacy Badger) and could open the page fine. Same btw for Windows Store links.

    0_1499872428045_Aufnahme3.png

    Any idea why this is?



  • Same snapshot as yours and the page renders ok for me, uBlock Origin is active. I have no account there btw, maybe there's a difference if you're signed in.



  • You should try and disable the extensions nevertheless, just to make sure they aren't causing you problems.


  • Vivaldi Translator

    The issue were saved cookies. I deleted all with "microsoft.com" and then I was able to open the page without a problem.

    Maybe this exception can be resolved by the browser instead of the user needing to manually delete cookies? I am a techie but a John Doe would just be annoyed with Vivaldi.


  • Moderator

    @dicks said in Can not open links to microsoft.com:

    The issue were saved cookies.

    If Microsoft's server detects a browser with a faulty algorithm, the server sets strange cookies to remind that for later, it is not the browsers fault.

    MS has gone better on their pages; in the past Vivaldi and ChrOpera were not detected at all or users forced to use Edge or IE 11.

    Maybe this exception can be resolved by the browser instead of the user needing to manually delete cookies?

    How should the browser detect that Microsoft's server has a problem and does wrong?
    You may have read that other posters here were able to load microsoft .com without problems.

    Perhaps the MS server had a temporary hickup or sickness!?



  • Lol, Microsoft is a bully, but they can't ignore that fact that over 60% of desktop users browse with some form of Chromium. They can't keep doing that.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.