Vivaldi stops loading pages, then won't open and stays in task manager



  • I've had this problem twice now in the past two days, where Vivaldi totally stops loading pages except seemingly whatever I was on at the time, then once it's closed it will refuse to open again and the process stays in Task Manager and can't be killed (even with powershell). The only thing that still works is the updater, and that fails because of the ghost process (see below). 0_1499612856928_photo_2017-07-10_00-42-14.jpg

    I did some searching on my phone when it happened last night, and the only similar thread I remember finding mentioned using a tool (OP of that thread recommended tweaking.com's Windows Repair) to repair and reset the registry, and that's what worked last night, but obviously I don't want to reset my defaults every day or so.

    I just wanted some insight into what this could be, and any fixes, as I've only found one answer that worked, and others (like an antivirus blocking Vivaldi) can't be it because Window Defender isn't blocking it at all.


  • Moderator

    Closing all running/crashed Vivaldi processes can take up to 1 minute as i remember.
    On Windows 7 i often got strange effects as the OS blocked suspended/terminated processes against killing by users.



  • Hi, check background apps too.
    Copy past vivaldi://chrome/settings/search#hardware
    to switch off.

    Cheers, mib



  • I'm seeing the same behavior here on my Windows 7 machine. The last time I used Vivaldi was two days ago because I'm in the middle of a large research project and V wasn't updating pages with newly entered input to my "pay-to-play" online tool. I will add that it's new behavior since the last snapshot. This morning I opened Vivaldi and checked for updates first thing and got the same behavior described by lotto77. I told the installer to close V and install. The installer window closed then.....nothing. The browser stayed open, no install, no message, no error warning. I waited for a minute or two and tried again..same thing. Closed Vivaldi, checked and there were 2 V processes running but no visible browser window. Now I have 2 concerns...if it's Windows 7 refusing to close terminated processes why just Vivaldi?....why did Vivaldi stop allowing me to input to my online tool with the last snapshot? It's like it didn't want to refresh pages in real time. Have installed the latest snapshot and we'll see how it goes.



  • I've had the same issue with Windows 8. Vivaldi has gone from my favorite browser to my least favorite since the last update. Now it takes forever to open, loads pages painfully slow, and locks up. Sad



  • Okay, so I got a (maybe temporary) fix working, seems like the installer makes a couple of new .exe's called new_vivaldi and old_vivaldi, and puts old vivaldi in a temp folder. For whatever reason old vivaldi was the one running and that's the one that wouldn't stop (and, may I just clarify that there's NO way to stop it, taskkill /f just fails and says "There is no running instance of this task"), and so to fix it I rebooted and deleted that before reopening Vivaldi.

    That all seems to be working fine, but I'll have to see if the updater actually works now before I know if it was a one-off or if it's an issue with updating itself.



  • The problem continued this morning so I rebooted, opened TM found no Vivaldi in running processes. Opened Vivaldi then exited, waited a minute or two, opened TM and 2 Vivaldi running in processes. Ended those processes (luckily it worked for me), closed TM and opened Vivaldi again...then exited, checked and both were back. I opened Chrome, to see if something similar was happening with that browser, then exited, checked and no Chrome in processes. BUT...very odd....the next time I opened Vivaldi and exited, then checked Task Manager, all instances of Vivaldi in running processes were gone and things appear normal in that regard. Now just need to check it with my research site to see if notes and changes will be applied in this snapshot.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.