Browser occasionally opens with no menus, tabs, options



  • Running Windows 10, 1.10.862.6 (Official Build) (64-bit)

    My wife and I have been using Vivaldi for over a year now and are generally happy. However, over the last few weeks she's started to see a problem where instead of restarting with the last session, the browser will open with either one page from the session or else just the start page, like these examples below (forget what's on the page, it's the browser frame I'm concerned with):
    alt text

    alt text
    (that's just the top of the page, the Speed Dial tiles were all there).

    As you can see, none of the menus are present. The only way of bringing back the regular look, with the Toolbar, Tabs, Search, Status bar etc., is to run a CCleaner, but she doesn't want to have to do that every time there's a Vivaldi problem.

    It's actually doing almost exactly the same for me on my own PC - if I right click on the Vivaldi icon from the Windows 10 task bar and select "New Window" or "New Incognito Window" I get this below - it's identical no matter whether it's 'regular' or Incognito:
    alt text
    instead of the usual:
    alt text
    Opening a new window from File at the top of the page works as it should, but in my wife's case, she doesn't have 'File' there until she's run CCleaner and restarted Vivaldi.

    Any thoughts (other than 'get your wife to listen to better music' ;) ) would be appreciated. Thanks!


  • Moderator

    @BillyBones That's not the browser. That's a secondary, popup or extra window. Make sure all such are closed before you shut down the browser. Then check your Windows Task Manager to ensure there are no active Vivaldi processes before you restart. This should NOT be necessary (it is not here, for instance) but try it anyway and see what happens.



  • @Ayespy Thanks for the prompt reply. Right... I just closed Vivaldi and ensured it's no longer running in Task Manager. I reopened it by clicking on the Start Menu icon and it opened in exactly the same way as above (with no menus, etc), showing the page that was previously there (so it saved that much). I'm assuming that's because the browser is set to open with the last saved session?

    Still, after clearing Vivaldi from the Task Manager then opening (single click) on the Vivaldi icon from my Start Menu/Taskbar or Desktop icons brings back that same 'popup' window rather than the full-on browser, as does any selection from the Right-click menu. Clicking a link to open in a new tab simply replaces the content of the popup window itself rather than creating any tabs.

    Oh and another related thing - I can't type in the address bar while it's like this.


  • Moderator

    @BillyBones It's possible your profile may have corrupted files. What happens if you refresh your profile?



  • @Ayespy I've refreshed it (thanks for including the link to instructions) and dragged select folders over from the backup 'Default' folder I created. So far your advice seems to have the problem fixed!

    I'll keep you posted either way, since I hate reading when people look for a solution then suddenly stop replying once they've got it figured out without letting people know exactly what worked.

    In the meantime thanks very much for your time & help :)


  • Moderator



  • I've the same problem. Vivaldi should not save the state of the latest window session if the window is a popup. Solving this by refreshing the profile is a pretty bad option...



  • Deleting files "Current Session" and "Last Session" from the default profile seems to fix the problem (close Vivaldi before)



  • Two days on and all still appears to be well, so it looks like creating a new profile was the answer. If it happens again I'll likely try rlebrette's suggestion (quoted below) rather than removing the whole profile and re-building it and see how that goes.

    @rlebrette said in Browser occasionally opens with no menus, tabs, options:

    Deleting files "Current Session" and "Last Session" from the default profile seems to fix the problem (close Vivaldi before)

    Thanks again to Ayespy for helping to get this issue fixed :)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.