src="https://update.vivaldi.com/stats/piwik.php?idsite=1&rec=1&bots=1" style="border:0;" alt=""

Vivaldi 1.10+ user agent string incorrectly reporting version of Vivaldi



  • Hello,

    The Vivaldi 1.10+ user agent string is incorrectly reporting the version of Vivaldi.

    For example, the Vivaldi 1.10.867.42 64-bit user agent string is mozilla/5.0 (windows nt 6.1; win64; x64) applewebkit/537.36 (khtml, like gecko) chrome/59.0.3071.104 safari/537.36 vivaldi/1.91.867.42.

    Or do you have a new policy for reporting the version of Vivaldi in the user agent string? If yes, please explain.

    Regards,

    Steve


  • Moderator

    @stevevv As I replied to you on the blog, it's on purpose. Some websites are so stupid they deprecate 1.10 because they think it's the same as 1.1, ie older than 1.9. Therefore, they warn you to update or refuse to deliver content. Therefore, 1.10 is 1.91 and 1.11 will be 1.92 or 1.911 in the user agent string.



  • Thank you for the reply. Regards, Steve


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.